summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/julius/files/julius-1.4.1-rename.patch26
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild17
2 files changed, 34 insertions, 9 deletions
diff --git a/games-strategy/julius/files/julius-1.4.1-rename.patch b/games-strategy/julius/files/julius-1.4.1-rename.patch
new file mode 100644
index 000000000000..cf6b6d53aadd
--- /dev/null
+++ b/games-strategy/julius/files/julius-1.4.1-rename.patch
@@ -0,0 +1,26 @@
+Avoid conflict with app-accessibility/julius.
+
+diff --color -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-06-01 14:53:28.000000000 +0100
++++ b/CMakeLists.txt 2021-02-14 11:51:30.364704957 +0000
+@@ -27,7 +27,7 @@
+ endif()
+ endif()
+
+-set(SHORT_NAME julius)
++set(SHORT_NAME julius-game)
+ project(${SHORT_NAME} C)
+
+ if (VITA_BUILD)
+diff --color -Naur a/res/julius.desktop b/res/julius.desktop
+--- a/res/julius.desktop 2020-06-01 14:53:28.000000000 +0100
++++ b/res/julius.desktop 2021-02-14 11:51:45.518122772 +0000
+@@ -2,7 +2,7 @@
+ [Desktop Entry]
+ Type=Application
+ Version=1.0
+-Exec=julius
++Exec=julius-game
+ Icon=com.github.bvschaik.julius
+ Name=Julius
+ GenericName=Roman city management game
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
index bffe7ad84787..dc3f63777c18 100644
--- a/games-strategy/julius/julius-1.4.1.ebuild
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg
+inherit xdg cmake
DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
HOMEPAGE="https://github.com/bvschaik/julius"
@@ -18,19 +18,18 @@ DEPEND="
media-libs/libsdl2[joystick,video,sound]
media-libs/sdl2-mixer
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
-src_prepare() {
- cmake_src_prepare
- xdg_src_prepare
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-rename.patch
+)
src_install() {
insinto /etc/profile.d
doins "${FILESDIR}"/90julius.sh
cmake_src_install
- mv "${ED}"/usr/bin/julius "${ED}"/usr/bin/julius-game ||
- die "Failed to rename executable (required as per conflict with app-accessibility/julius)"
}
pkg_postinst() {