summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocaml-conduit/Manifest2
-rw-r--r--dev-ml/ocaml-conduit/files/lwt3.patch58
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild45
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild49
4 files changed, 0 insertions, 154 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
index 2fa87853e3cd..d415e3ea7967 100644
--- a/dev-ml/ocaml-conduit/Manifest
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -1,3 +1 @@
-DIST ocaml-conduit-0.14.5.tar.gz 38471 SHA256 00aba333c05866bb712f7890c6f9fd457b85cf592d28adc6636413032683f86f SHA512 c2de6518588e3555cd40dfc6c1ce6d809dc570ddb6a07fb8ccce1797469e9c28ea1a633d4a1b360bf15cdb95e6231ecb0be8bd44e4654baa5268f09519096b52 WHIRLPOOL 5e052d7b9d34d76662496739a6934bf64c1930ca64b2160aa8cbefe0237bd0bb3438a187c3dd05d841b7b475325afcb32bb6fb20e0b61b885c16f4b0b3259aea
-DIST ocaml-conduit-0.15.0.tar.gz 38617 SHA256 fa8c812c1e87cc59e7f6f8fd6d716014aadeda9853e5c6feacd5ecdd1fec5815 SHA512 112a09df2edc7bb0f174f19ad7d826aaf8116cce86e66182a27b4edadcffeee632d7e5cad489e9e797147b94ec81b1f1d122e9e30e384c0c84847875f9bed096 WHIRLPOOL 80bc7aa47df74c4a17c60e26bc9fd34a2167682cc63821918b33e03429f35710882a244aed61578d1e8ac7a34f67d3ba65e40754e066109b433a50868e73c243
DIST ocaml-conduit-0.15.3.tar.gz 38921 SHA256 6760c9fed6b1c5360d74b4cd6fafbd78e1736c08d3024ed9ecb79b29ad3456db SHA512 0666ed22a93351dc8381de3eaafcf019336f9d62e6b7ed7c0bcd7e202ecfb54ede8ed999023a0ed712da6406cee872965b22c77982ed65897b2e0abfadd0a07c WHIRLPOOL e754553c08fe31be337b8f1aaf504a5319af66aea9f897b411a6ca4d8efd4a5c1ac9488cbe7ca091f7c87ce4171e3725f701a9f8359d04dfd6c6cca350a1a611
diff --git a/dev-ml/ocaml-conduit/files/lwt3.patch b/dev-ml/ocaml-conduit/files/lwt3.patch
deleted file mode 100644
index de849e60d79a..000000000000
--- a/dev-ml/ocaml-conduit/files/lwt3.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Index: ocaml-conduit-0.15.0/lib/conduit_lwt_server.ml
-===================================================================
---- ocaml-conduit-0.15.0.orig/lib/conduit_lwt_server.ml
-+++ ocaml-conduit-0.15.0/lib/conduit_lwt_server.ml
-@@ -15,10 +15,10 @@ let close (ic, oc) =
- let listen ?(backlog=128) sa =
- let fd = Lwt_unix.socket (Unix.domain_of_sockaddr sa) Unix.SOCK_STREAM 0 in
- Lwt_unix.(setsockopt fd SO_REUSEADDR true);
-- Lwt_unix.bind fd sa;
-+ Lwt_unix.bind fd sa >>= fun _ ->
- Lwt_unix.listen fd backlog;
- Lwt_unix.set_close_on_exec fd;
-- fd
-+ Lwt.return fd
-
- let with_socket sockaddr f =
- let fd =
-Index: ocaml-conduit-0.15.0/lib/conduit_lwt_server.mli
-===================================================================
---- ocaml-conduit-0.15.0.orig/lib/conduit_lwt_server.mli
-+++ ocaml-conduit-0.15.0/lib/conduit_lwt_server.mli
-@@ -3,7 +3,7 @@ val close : 'a Lwt_io.channel * 'b Lwt_i
-
- val set_max_active : int -> unit
-
--val listen : ?backlog:int -> Unix.sockaddr -> Lwt_unix.file_descr
-+val listen : ?backlog:int -> Unix.sockaddr -> Lwt_unix.file_descr Lwt.t
-
- val with_socket
- : Unix.sockaddr
-Index: ocaml-conduit-0.15.0/lib/conduit_lwt_unix.ml
-===================================================================
---- ocaml-conduit-0.15.0.orig/lib/conduit_lwt_unix.ml
-+++ ocaml-conduit-0.15.0/lib/conduit_lwt_unix.ml
-@@ -167,11 +167,12 @@ let init ?src ?(tls_server_key=`None) ()
- module Sockaddr_client = struct
- let connect ?src sa =
- Conduit_lwt_server.with_socket sa (fun fd ->
-- let () =
-+ let tx () =
- match src with
-- | None -> ()
-+ | None -> Lwt.return ()
- | Some src_sa -> Lwt_unix.bind fd src_sa
-- in
-+ in
-+ tx () >>= fun () ->
- Lwt_unix.connect fd sa >>= fun () ->
- let ic = Lwt_io.of_fd ~mode:Lwt_io.input fd in
- let oc = Lwt_io.of_fd ~mode:Lwt_io.output fd in
-@@ -199,6 +200,7 @@ module Sockaddr_server = struct
- match on with
- | `Socket s -> s
- | `Sockaddr sockaddr -> Conduit_lwt_server.listen ?backlog sockaddr in
-+ s >>= fun s ->
- Conduit_lwt_server.init ?stop (process_accept ?timeout callback) s
- end
-
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
deleted file mode 100644
index 8e5f0e391013..000000000000
--- a/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib
-
-DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
-HOMEPAGE="https://github.com/mirage/ocaml-conduit"
-SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- dev-lang/ocaml:=
- dev-ml/sexplib:=
- dev-ml/stringext:=
- dev-ml/ocaml-uri:=
- dev-ml/logs:=
- dev-ml/ocaml-cstruct:=
- dev-ml/ocaml-ipaddr:=
-
- dev-ml/lwt:=
- dev-ml/async:=
- dev-ml/ocaml-dns:=
- dev-ml/ocaml-ssl:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
- dev-ml/ppx_driver
- dev-ml/ppx_optcomp
- dev-ml/ppx_sexp_conv
-"
-
-DOCS=( TODO.md README.md CHANGES )
-
-src_install() {
- findlib_src_preinst
- default
-}
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
deleted file mode 100644
index cd8c6a3b6ccc..000000000000
--- a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
-HOMEPAGE="https://github.com/mirage/ocaml-conduit"
-SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- dev-lang/ocaml:=
- dev-ml/sexplib:=
- dev-ml/stringext:=
- dev-ml/ocaml-uri:=
- dev-ml/logs:=
- dev-ml/ocaml-cstruct:=
- dev-ml/ocaml-ipaddr:=
-
- >=dev-ml/lwt-3:=
- dev-ml/async:=
- dev-ml/ocaml-dns:=
- dev-ml/ocaml-ssl:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
- dev-ml/ppx_driver
- dev-ml/ppx_optcomp
- dev-ml/ppx_sexp_conv
-"
-
-DOCS=( TODO.md README.md CHANGES )
-
-src_prepare() {
- epatch "${FILESDIR}/lwt3.patch"
-}
-
-src_install() {
- findlib_src_preinst
- default
-}