summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter-client/Manifest1
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.5.0.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 4af1f7a9d56d..57f31a992f86 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,2 +1 @@
-DIST jupyter_client-8.5.0.tar.gz 339190 BLAKE2B e102a457e5148199ac1b367cca1bb2f8e64b5fdda41c3e08ddc3e7d30992b53b8a228339151be9d63311e0c45a4487aefdf23785b773830631b3695bd3a7cabf SHA512 256fde7866b66e263d3b03afd8d8a0fddce23513c37375ab255398d1ed2cad5df87b753b577b8f6634ffe4ab4d55a82afd134444fc7714c4f3846d7d3a66f353
DIST jupyter_client-8.6.0.tar.gz 339721 BLAKE2B 80786453526899cfff2e5335009d90f0dd636da33a5778868ba8913be488e9c1512beffc1b5e658dee215bdee9e264c9a5c6621490c2efb8f4784557735f736e SHA512 84e913c46f5e0298b699c4d1c6de27fd2b9861bc29f7a5a456c20c7100aaedf399eb6c09ff28bd3bb20945a3bea84bd0bda8688f32815fa7bdd375f091817e4a
diff --git a/dev-python/jupyter-client/jupyter-client-8.5.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.5.0.ebuild
deleted file mode 100644
index 3c00dda12f5a..000000000000
--- a/dev-python/jupyter-client/jupyter-client-8.5.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter_client/
- https://pypi.org/project/jupyter-client/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
- ' 3.{8,9})
-"
-BDEPEND="
- test? (
- >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
- >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO: times out
- tests/test_client.py::TestAsyncKernelClient::test_input_request
- # TODO
- tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
-)