summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/bwm-ng/Manifest1
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.2.ebuild38
-rw-r--r--net-analyzer/bwm-ng/files/bwm-ng-0.6.2-tinfo.patch10
3 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/Manifest b/net-analyzer/bwm-ng/Manifest
index ce662ef5c6e8..44c35c9cce13 100644
--- a/net-analyzer/bwm-ng/Manifest
+++ b/net-analyzer/bwm-ng/Manifest
@@ -1 +1,2 @@
DIST bwm-ng-0.6.1.tar.gz 162620 BLAKE2B 28e201ac681fcb1d79afead8a7d2c31d52bfa9ee1ebc132d3cd1080a7edd8ddcc8c0cd6df1897d23a1c79a4a5d9157214a8f3224bd5f8f2c1a12cad96ec188bd SHA512 3f8d4a10f5cbf743d6aee9c6170f334c4274224a2f1886f04338c9a1bf0cf13af5be4aaea0445c9e5b5d361915cc3a93bbfe7c4abf69a0d24e42bc414d8056cd
+DIST bwm-ng-0.6.2.tar.gz 70079 BLAKE2B 4e0c5dd73bdcaabf5138ce842e5ce50709ba3bc0792f11ebee2640b6246f5bd740fcf8ad79b7dcffabdbc8f44c5ec2d925b20cf28609f8735e537f6920f92aba SHA512 4a7f141692f96dfab0c1729a7df36f5213a75ddb891b967b2cf951419daea7b84354c276705a0ee7c09f4ed26948ca068f65a04b8f9d18b2b8ed2df97b5e3b0a
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.2.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.2.ebuild
new file mode 100644
index 000000000000..23c71582d272
--- /dev/null
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Bandwidth Monitor NG is a small and simple console-based bandwidth monitor"
+HOMEPAGE="http://www.gropp.org/"
+SRC_URI="https://github.com/vgropp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+csv +html"
+
+RDEPEND="
+ >=sys-apps/net-tools-1.60-r1
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable csv) \
+ $(use_enable html) \
+ --with-ncurses \
+ --with-procnetdev
+}
diff --git a/net-analyzer/bwm-ng/files/bwm-ng-0.6.2-tinfo.patch b/net-analyzer/bwm-ng/files/bwm-ng-0.6.2-tinfo.patch
new file mode 100644
index 000000000000..a51f9c0596aa
--- /dev/null
+++ b/net-analyzer/bwm-ng/files/bwm-ng-0.6.2-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -52,6 +52,7 @@
+ CPPFLAGS="$CPPFLAGS -I$withval"
+ fi
+ AC_CHECK_LIB([ncurses],[newterm,timeout],,[ CPPFLAGS=$OLD_CPPFLAGS ])
++ AC_SEARCH_LIBS([wtimeout],[tinfo])
+ CURSES_CHECKED="1"
+ else
+ CURSES_CHECKED="1"