summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--perl-core/Test-Simple/Manifest2
-rw-r--r--perl-core/Test-Simple/Test-Simple-1.302.75.ebuild46
-rw-r--r--perl-core/Test-Simple/Test-Simple-1.302.96.ebuild48
-rw-r--r--perl-core/Test-Simple/metadata.xml15
-rw-r--r--profiles/package.mask4
-rw-r--r--virtual/perl-Test-Simple/perl-Test-Simple-1.302.96.ebuild (renamed from virtual/perl-Test-Simple/perl-Test-Simple-1.302.75.ebuild)0
6 files changed, 65 insertions, 50 deletions
diff --git a/perl-core/Test-Simple/Manifest b/perl-core/Test-Simple/Manifest
index bde68e60278d..eab2b8559436 100644
--- a/perl-core/Test-Simple/Manifest
+++ b/perl-core/Test-Simple/Manifest
@@ -1,2 +1,2 @@
DIST Test-Simple-1.001014.tar.gz 127212 SHA256 55a414ce89eb7a5e9e84186f286b002054f10ae8ef4f8f2d61bb710e7549f16b SHA512 0aa0b4d78c0243480df0e7f9b28d69b6bbf1b26bd49a91827c2d61595319840f7178f179555a60ef28d49d3f50679aade4f6d8138e9ae1bd0113a3d6c66d89c2 WHIRLPOOL 554c292cc05e31c0f82094ff23a556d46526388f9b51b7c3367fb1c34ed692c03b03b1be46f75f6b9186bcd52b3a4e613064252c8f6234ef5711da2a29bec3a7
-DIST Test-Simple-1.302075.tar.gz 255843 SHA256 86f2205498f96302e00331ac586bf366547e946e8637ad208d6317a2097d40b7 SHA512 ebd6fe42458b4608f8f54bf35f062dbb767bc48659e262a794f8383de206b28c7e5acbc9418301dc0f5ca0a43602c17caa49be1a8a8ce2ad0fc836e31ca32239 WHIRLPOOL f753e8ea5c8cad6bb09b347f20a0848f4c0f2f0df2015f052b76d8e58108cd6a8df94a8c5eab7731fbe14cca27340245a67f602a754896b2f0e9d8f936ff1711
+DIST Test-Simple-1.302096.tar.gz 282450 SHA256 314b38cb33fb608c352bd895431cf504b14642ff8714831c410f30877019dc11 SHA512 85ff954c2031bc53e9af56e6e3c42dcf1ca0f6e10bccd5e4aaf23b58dc6f07b5c1c0cd55b10588e91581e58c41130afbc7c4a93ed078f475584879320eb60dbc WHIRLPOOL 8a97c557ed31f349941e4449a8d90cb857d6e6f3ee3419bbe7356bd25eaee8cd614500796c25657368fd3a020a6e711ddeec38fd9fc53b8215639584a54058ca
diff --git a/perl-core/Test-Simple/Test-Simple-1.302.75.ebuild b/perl-core/Test-Simple/Test-Simple-1.302.75.ebuild
deleted file mode 100644
index 5499620f0a4e..000000000000
--- a/perl-core/Test-Simple/Test-Simple-1.302.75.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=EXODIST
-DIST_VERSION=1.302075
-DIST_EXAMPLES=("examples/*")
-inherit perl-module
-
-DESCRIPTION="Basic utilities for writing tests"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="
- !<dev-perl/Test-Tester-0.114.0
- !<dev-perl/Test-use-ok-0.160.0
- !<dev-perl/Log-Dispatch-Config-TestLog-0.20.0
- !<dev-perl/Net-BitTorrent-0.52.0
- !<dev-perl/Moose-2.120.900
- !<dev-perl/Test-Able-0.110.0
- !<dev-perl/Test-Aggregate-0.373.0
- !<dev-perl/Test-Alien-0.40.0
- !<dev-perl/Test-Builder-Clutch-0.70.0
- !<dev-perl/Test-Clustericious-Cluster-0.300.0
- !<dev-perl/Test-Dist-VersionSync-1.1.4
- !<dev-perl/Test-Exception-0.420.0
- !<dev-perl/Test-Flatten-0.110.0
- !<dev-perl/Test-Group-0.200.0
- !<dev-perl/Test-Modern-0.12.0
- !<dev-perl/Test-More-Prefix-0.5.0
- !<dev-perl/Test-ParallelSubtest-0.50.0
- !<dev-perl/Test-Pretty-0.320.0
- !<dev-perl/Test-SharedFork-0.340.0
- !<dev-perl/Test-Wrapper-0.3.0
- !<dev-perl/Test-UseAllModules-0.140.0
- virtual/perl-File-Spec
- virtual/perl-File-Temp
- >=virtual/perl-Scalar-List-Utils-1.130.0
- virtual/perl-Storable
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
diff --git a/perl-core/Test-Simple/Test-Simple-1.302.96.ebuild b/perl-core/Test-Simple/Test-Simple-1.302.96.ebuild
new file mode 100644
index 000000000000..f08dd4ea2c5b
--- /dev/null
+++ b/perl-core/Test-Simple/Test-Simple-1.302.96.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EXODIST
+DIST_VERSION=1.302096
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Basic utilities for writing tests"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ !<dev-perl/Test-Tester-0.114.0
+ !<dev-perl/Test-use-ok-0.160.0
+ !<=dev-perl/Log-Dispatch-Config-TestLog-0.20.0
+ !<=dev-perl/Net-BitTorrent-0.52.0
+ !<=dev-perl/Moose-2.120.900
+ !<=dev-perl/Test-Able-0.110.0
+ !<=dev-perl/Test-Aggregate-0.373.0
+ !<=dev-perl/Test-Alien-0.40.0
+ !<=dev-perl/Test-Builder-Clutch-0.70.0
+ !<=dev-perl/Test-Clustericious-Cluster-0.300.0
+ !<=dev-perl/Test-Dist-VersionSync-1.1.4
+ !<=dev-perl/Test-Exception-0.420.0
+ !<=dev-perl/Test-Flatten-0.110.0
+ !<=dev-perl/Test-Group-0.200.0
+ !<=dev-perl/Test-Modern-0.12.0
+ !<=dev-perl/Test-More-Prefix-0.5.0
+ !<=dev-perl/Test-ParallelSubtest-0.50.0
+ !<=dev-perl/Test-Pretty-0.320.0
+ !<=dev-perl/Test-SharedFork-0.340.0
+ !<=dev-perl/Test-Wrapper-0.3.0
+ !<=dev-perl/Test-UseAllModules-0.140.0
+ !<=dev-perl/Test2-Harness-0.0.13
+ !<=dev-perl/Test2-Tools-EventDumper-0.0.7
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+ virtual/perl-Storable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/perl-core/Test-Simple/metadata.xml b/perl-core/Test-Simple/metadata.xml
index c0d99849be16..b84ffd6ebe36 100644
--- a/perl-core/Test-Simple/metadata.xml
+++ b/perl-core/Test-Simple/metadata.xml
@@ -18,15 +18,27 @@
<remote-id type="cpan-module">Test2::Event::Diag</remote-id>
<remote-id type="cpan-module">Test2::Event::Encoding</remote-id>
<remote-id type="cpan-module">Test2::Event::Exception</remote-id>
+ <remote-id type="cpan-module">Test2::Event::Fail</remote-id>
<remote-id type="cpan-module">Test2::Event::Generic</remote-id>
- <remote-id type="cpan-module">Test2::Event::Info</remote-id>
<remote-id type="cpan-module">Test2::Event::Note</remote-id>
<remote-id type="cpan-module">Test2::Event::Ok</remote-id>
+ <remote-id type="cpan-module">Test2::Event::Pass</remote-id>
<remote-id type="cpan-module">Test2::Event::Plan</remote-id>
<remote-id type="cpan-module">Test2::Event::Skip</remote-id>
<remote-id type="cpan-module">Test2::Event::Subtest</remote-id>
<remote-id type="cpan-module">Test2::Event::TAP::Version</remote-id>
<remote-id type="cpan-module">Test2::Event::Waiting</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::About</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Amnesty</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Assert</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Control</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Error</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Info</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Meta</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Parent</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Plan</remote-id>
+ <remote-id type="cpan-module">Test2::EventFacet::Trace</remote-id>
<remote-id type="cpan-module">Test2::Formatter</remote-id>
<remote-id type="cpan-module">Test2::Formatter::TAP</remote-id>
<remote-id type="cpan-module">Test2::Hub</remote-id>
@@ -39,6 +51,7 @@
<remote-id type="cpan-module">Test2::Tools::Tiny</remote-id>
<remote-id type="cpan-module">Test2::Util</remote-id>
<remote-id type="cpan-module">Test2::Util::ExternalMeta</remote-id>
+ <remote-id type="cpan-module">Test2::Util::Facets2Legacy</remote-id>
<remote-id type="cpan-module">Test2::Util::HashBase</remote-id>
<remote-id type="cpan-module">Test2::Util::Trace</remote-id>
<remote-id type="cpan-module">Test::Builder</remote-id>
diff --git a/profiles/package.mask b/profiles/package.mask
index 01b6846c2900..b6ed1981ae63 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -500,8 +500,8 @@ dev-ruby/poltergeist
>=dev-perl/Net-Twitter-4.10.420
>=perl-core/Math-BigInt-1.999.726
>=dev-perl/Math-BigInt-GMP-1.600.0
-=perl-core/Test-Simple-1.302.75
-=virtual/perl-Test-Simple-1.302.75
+=perl-core/Test-Simple-1.302.96
+=virtual/perl-Test-Simple-1.302.96
dev-perl/Test2-Suite
>=dev-perl/Data-Validate-Domain-0.120.0
dev-perl/Test2-Plugin-NoWarnings
diff --git a/virtual/perl-Test-Simple/perl-Test-Simple-1.302.75.ebuild b/virtual/perl-Test-Simple/perl-Test-Simple-1.302.96.ebuild
index fbe8a3ef5612..fbe8a3ef5612 100644
--- a/virtual/perl-Test-Simple/perl-Test-Simple-1.302.75.ebuild
+++ b/virtual/perl-Test-Simple/perl-Test-Simple-1.302.96.ebuild