summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/doc8/Manifest1
-rw-r--r--dev-python/doc8/doc8-1.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index fb17f7905116..4b2303805e7a 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1 +1,2 @@
DIST doc8-0.11.2.tar.gz 25898 BLAKE2B 097c6d6b82fe4acf7cfc43ff7860334f0a53df3ca39def33de4b9f04553acab785fe339d8126dd5ae56a7d45c846c575b9c689eed47bc47302b89fd5bfabfe3a SHA512 f607251c3ae792b3210893b2074bb34aad866a54645c4244ef53e156a4c3af9cfb61ddb93617d153510cc6868be7f04409eac47f66f91d4d0b9400bb7aca0eb1
+DIST doc8-1.0.0.tar.gz 26058 BLAKE2B 0113a4738804a9ed0446ae26b18f0f7da9dd3c4a90c598e03c78d3124f5db42dbc38f1f17af05ef60cb645a8b18bcb20aeb2f5cc00c44814afd572d92b2d0301 SHA512 98ad904a994536de80d6e89a221e3d7159d5188a0f57d07961f646e0591f81790f06c624ef90c32e28ff89ecf9e39b2b052363995aaece6a4e30f643c37964b9
diff --git a/dev-python/doc8/doc8-1.0.0.ebuild b/dev-python/doc8/doc8-1.0.0.ebuild
new file mode 100644
index 000000000000..9e86c190ebaa
--- /dev/null
+++ b/dev-python/doc8/doc8-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/pycqa/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest