summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/files/kwayland-integration-5.91.0-kwindowsystem-no-widgets.patch68
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.91.0.ebuild45
3 files changed, 114 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 2d7ce375e965..b4334baba8a3 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.27.10.tar.xz 25776 BLAKE2B dbd1b2cedf1128f59318e41036bde63c8062538804a6b26418bce2210860a0b0f1dcbf217f9b823924ec8865b2bc3d6ceae7a06339d8ea1a508d67763e697027 SHA512 c66b08ba2af7675add7d603e0b8bdd20578abfc71af15574c389c8bec9856f309fe856c236f9fc8832e38c0125f5d55a3cc3d649b9d49733ee93d656b9c293fe
DIST kwayland-integration-5.27.9.tar.xz 25776 BLAKE2B dba48b7405edbaa885e1abe938806022546ab5c485f1ef20799399bbd7e97c618a7a2c0755561880f45a28e57b0cd17bb2e219f7af102f86bff638787d4460cf SHA512 aaea32038eb9098387d819e9c9dcff4f5b4634841614a0a5c5db9528a6f51d5197cab5ee24dccfbba400b7c012f6360248b4d8c64948c79ee7a545009a64594f
+DIST kwayland-integration-5.91.0.tar.xz 26352 BLAKE2B 0a3dd88dfa1c0804e128b20c9b6ed8d28de534a19cac4c22584050e8903cc83a9629431e10759125112a486215980fe1bac10d38537fc0e79bd9ed1277a1e250 SHA512 04b68fc1572bf6218bb8dd2e09fbed2c7dfb7ea91581a5d0503cac40865fb83597d537cf4c12a0cbb56d134c585148c4d3f1bb6ff2e52b26231c8be4eddc3baa
diff --git a/kde-plasma/kwayland-integration/files/kwayland-integration-5.91.0-kwindowsystem-no-widgets.patch b/kde-plasma/kwayland-integration/files/kwayland-integration-5.91.0-kwindowsystem-no-widgets.patch
new file mode 100644
index 000000000000..5fc4f0092530
--- /dev/null
+++ b/kde-plasma/kwayland-integration/files/kwayland-integration-5.91.0-kwindowsystem-no-widgets.patch
@@ -0,0 +1,68 @@
+From b672d78b8fa59e0e41dab7d06816ea751f24b461 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 16 Dec 2023 19:57:03 +0100
+Subject: [PATCH] Fix build against KF5WindowSystem with
+ -DKWINDOWSYSTEM_NO_WIDGETS=ON
+
+Deprecation #ifdefs got lost between 1102b5470e0573efe817ca12e649977007d3e6c0 and 4a3ae83979507598fae29d1b6d0a449779fda5eb.
+
+5.101 deprecation #ifdefs are still missing after this change.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/windowsystem/windowsystem.cpp | 4 ++++
+ src/windowsystem/windowsystem.h | 2 ++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/src/windowsystem/windowsystem.cpp b/src/windowsystem/windowsystem.cpp
+index 9266ddd..6f67129 100644
+--- a/src/windowsystem/windowsystem.cpp
++++ b/src/windowsystem/windowsystem.cpp
+@@ -192,12 +192,14 @@ QPoint WindowSystem::desktopToViewport(int desktop, bool absolute)
+ return QPoint();
+ }
+
++#if KWINDOWSYSTEM_BUILD_DEPRECATED_SINCE(5, 0)
+ WId WindowSystem::groupLeader(WId window)
+ {
+ Q_UNUSED(window)
+ qCDebug(KWAYLAND_KWS) << "This plugin does not support group leader";
+ return 0;
+ }
++#endif
+
+ bool WindowSystem::icccmCompliantMappingState()
+ {
+@@ -549,12 +551,14 @@ QList<WId> WindowSystem::stackingOrder()
+ return QList<WId>();
+ }
+
++#if KWINDOWSYSTEM_BUILD_DEPRECATED_SINCE(5, 0)
+ WId WindowSystem::transientFor(WId window)
+ {
+ Q_UNUSED(window)
+ qCDebug(KWAYLAND_KWS) << "This plugin does not support transient for windows";
+ return 0;
+ }
++#endif
+
+ int WindowSystem::viewportToDesktop(const QPoint &pos)
+ {
+diff --git a/src/windowsystem/windowsystem.h b/src/windowsystem/windowsystem.h
+index 8c978e6..c59675a 100644
+--- a/src/windowsystem/windowsystem.h
++++ b/src/windowsystem/windowsystem.h
+@@ -42,8 +42,10 @@ public:
+ void setOnAllDesktops(WId win, bool b) override;
+ void setOnDesktop(WId win, int desktop) override;
+ void setOnActivities(WId win, const QStringList &activities) override;
++#if KWINDOWSYSTEM_BUILD_DEPRECATED_SINCE(5, 0)
+ WId transientFor(WId window) override;
+ WId groupLeader(WId window) override;
++#endif
+ QPixmap icon(WId win, int width, int height, bool scale, int flags) override;
+ void setIcons(WId win, const QPixmap &icon, const QPixmap &miniIcon) override;
+ void setType(WId win, NET::WindowType windowType) override;
+--
+GitLab
+
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.91.0.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.91.0.ebuild
new file mode 100644
index 000000000000..441f9d079db5
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.91.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${P}-kwindowsystem-no-widgets.patch" )