summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/elicense/elicense-9999.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
index a7cb3da3c328..bbba9eea7ef6 100644
--- a/app-portage/elicense/elicense-9999.ebuild
+++ b/app-portage/elicense/elicense-9999.ebuild
@@ -21,3 +21,16 @@ SLOT="0"
IUSE=""
RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ local MY_PV=${PV}
+ if [[ ${PV} == "9999" ]]; then
+ local last_commit=$(git rev-parse HEAD)
+ MY_PV="${last_commit:0:7}-git"
+ fi
+
+ sed -i -e "s/^MY_PV =.*$/MY_PV = \"${MY_PV}\"/" \
+ elicense || die "Failed to sed in version."
+}