summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/superlance/Manifest2
-rw-r--r--dev-python/superlance/metadata.xml13
-rw-r--r--dev-python/superlance/superlance-0.14.ebuild41
-rw-r--r--dev-python/superlance/superlance-1.0.0.ebuild41
4 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/superlance/Manifest b/dev-python/superlance/Manifest
deleted file mode 100644
index fe69fd80603c..000000000000
--- a/dev-python/superlance/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST superlance-0.14.tar.gz 36237 BLAKE2B dcf1f94ae1832b912c800945930bc57fed43a91c8ac3bcb9f523f0f683132091c080ae77932704213f424cd094bdaf08bf118be96b4573f46aa91bd86ed8e410 SHA512 41fdc9cf83ce636aea3665aed0fa9b1a37c2fe4d3740db694c20f60676d44ee6cc534ae038018edc0a1057607bac9dd4f0d14ea365735148a19a10e138723efd
-DIST superlance-1.0.0.tar.gz 36909 BLAKE2B 68d6e4e778abe78200b1047448c9016f578026231ac92987e3ca469b4f2cbbb6a3a70d7af00ed3ed3078121a9224d413592c27be461b8bf988b10b60f20f477b SHA512 f85dbd0768820e2f679b374c5178e6b74de21cebd813a485f615203784e25a968ddcbae72cae41dc56f4f105dab9a6ead16acf4d4cffa3cf30d91650ebb20611
diff --git a/dev-python/superlance/metadata.xml b/dev-python/superlance/metadata.xml
deleted file mode 100644
index ad375d27b2c1..000000000000
--- a/dev-python/superlance/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">superlance</remote-id>
- <remote-id type="github">Supervisor/superlance</remote-id>
- <bugs-to>https://github.com/Supervisor/superlance/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/superlance/superlance-0.14.ebuild b/dev-python/superlance/superlance-0.14.ebuild
deleted file mode 100644
index e84aeb9d1ee1..000000000000
--- a/dev-python/superlance/superlance-0.14.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A set of plugins to monitor and control supervisor"
-HOMEPAGE="https://github.com/Supervisor/superlance"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/superlance/superlance-1.0.0.ebuild b/dev-python/superlance/superlance-1.0.0.ebuild
deleted file mode 100644
index e84aeb9d1ee1..000000000000
--- a/dev-python/superlance/superlance-1.0.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A set of plugins to monitor and control supervisor"
-HOMEPAGE="https://github.com/Supervisor/superlance"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}