summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-embedded/platformio/Manifest2
-rw-r--r--dev-embedded/platformio/platformio-6.1.11.ebuild (renamed from dev-embedded/platformio/platformio-6.1.6-r2.ebuild)10
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index f4ae6a7f0739..9434f03835b0 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1 +1 @@
-DIST platformio-6.1.6.tar.gz 295288 BLAKE2B 4508f3eda25cbb2d2bad6881d7041a9bd8bb87b452564b3cabd58bec0506ca10e53b2552eee8ac1984cb429e5ea52c332d863f1c76a10b5106ab238e6506bb87 SHA512 879fbc759476118473d13375e4dcdbda901f48f5d0d9bb94bdd3ed09de2563603880b91d102e35eaf144e61cd457b132056e0a8293b762b3566a537f3b886078
+DIST platformio-6.1.11.gh.tar.gz 296333 BLAKE2B 17672b499eca9c828cd7c6ea6a4c8acea7287f42bb78d4fc5fbd11bb93175bb87d9c2d100270869bc99bc0db550b49c163555ddd8edb17b6b33ccc5f3623f768 SHA512 450e3d1dc3b9c8124b6254fbf0a05b207b834aa0661f083ee2915bde5064498b6d5af666ad851b737fa5627ed436db983e038f83ed0437a1e248749a0dcc99ba
diff --git a/dev-embedded/platformio/platformio-6.1.6-r2.ebuild b/dev-embedded/platformio/platformio-6.1.11.ebuild
index 5a870f66e445..98da137e5799 100644
--- a/dev-embedded/platformio/platformio-6.1.6-r2.ebuild
+++ b/dev-embedded/platformio/platformio-6.1.11.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 udev
DESCRIPTION="An open source ecosystem for IoT development"
HOMEPAGE="https://platformio.org/"
-SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}"/${PN}-core-${PV}
LICENSE="BSD"
@@ -29,11 +29,11 @@ RDEPEND="
<dev-python/pyserial-4[${PYTHON_USEDEP}]
>=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
=dev-python/requests-2*[${PYTHON_USEDEP}]
- >=dev-python/semantic-version-2.9[${PYTHON_USEDEP}]
+ >=dev-python/semantic-version-2.10[${PYTHON_USEDEP}]
<dev-python/semantic-version-3[${PYTHON_USEDEP}]
=dev-python/tabulate-0.9*[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.27[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.30[${PYTHON_USEDEP}]
<dev-python/pyelftools-1[${PYTHON_USEDEP}]
=dev-python/marshmallow-3*[${PYTHON_USEDEP}]
>=dev-python/starlette-0.21[${PYTHON_USEDEP}]