summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/ucpp/ucpp-1.3.5.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-devel/ucpp/ucpp-1.3.5.ebuild b/sys-devel/ucpp/ucpp-1.3.5.ebuild
index dd47d3413428..858f87bb784f 100644
--- a/sys-devel/ucpp/ucpp-1.3.5.ebuild
+++ b/sys-devel/ucpp/ucpp-1.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,17 +10,16 @@ SRC_URI="https://gitlab.com/scarabeusiv/${PN}/uploads/79f08e39c676f15ed8a59335f6
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="static-libs"
src_configure() {
econf \
--disable-werror \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- # package provides .pc files
- find "${D}" -name '*.la' -type f -delete || die
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
}