summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nrpe/nrpe-2.15-r3.ebuild10
-rw-r--r--net-analyzer/nrpe/nrpe-3.2.1.ebuild9
2 files changed, 13 insertions, 6 deletions
diff --git a/net-analyzer/nrpe/nrpe-2.15-r3.ebuild b/net-analyzer/nrpe/nrpe-2.15-r3.ebuild
index 90481423d1fe..afdbdc893c41 100644
--- a/net-analyzer/nrpe/nrpe-2.15-r3.ebuild
+++ b/net-analyzer/nrpe/nrpe-2.15-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,9 +11,13 @@ SRC_URI="mirror://sourceforge/nagios/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE="command-args minimal selinux ssl tcpd"
+IUSE="command-args libressl minimal selinux ssl tcpd"
-DEPEND="ssl? ( dev-libs/openssl:0 )
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
!minimal? ( tcpd? ( sys-apps/tcp-wrappers ) )"
RDEPEND="${DEPEND}
!minimal? (
diff --git a/net-analyzer/nrpe/nrpe-3.2.1.ebuild b/net-analyzer/nrpe/nrpe-3.2.1.ebuild
index fabe5f984cae..3a4f9d8d2513 100644
--- a/net-analyzer/nrpe/nrpe-3.2.1.ebuild
+++ b/net-analyzer/nrpe/nrpe-3.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,10 +11,13 @@ SRC_URI="${HOMEPAGE}/releases/download/${P}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="command-args selinux ssl"
+IUSE="command-args libressl selinux ssl"
DEPEND="sys-apps/tcp-wrappers
- ssl? ( dev-libs/openssl:0 )"
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
RDEPEND="${DEPEND}
|| ( net-analyzer/nagios-plugins net-analyzer/monitoring-plugins )
selinux? ( sec-policy/selinux-nagios )"