summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/metadata.xml1
-rw-r--r--games-emulation/snes9x/snes9x-1.55.ebuild125
3 files changed, 0 insertions, 127 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index e78bcb133c3e..43a9331b3fb9 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,3 +1,2 @@
-DIST snes9x-1.55.tar.gz 2252841 BLAKE2B 52b2e3d5539d95df63ef6f90c974895bc3a3dbe1e89b3a9513a8504eab308d4827f116ebc13fd89ac9c01f7394067eeddf7fd6f640fd071ee8558a6a79f2b56c SHA512 61d1d6f9c1fc4fbf6253ac7a7d214c771563d7d60238197b2f1525a58f8f9011446f400767d39ec464c69d80574a7dcd78557c8f47605df992af28cb107c0f6e
DIST snes9x-1.56.tar.gz 2876904 BLAKE2B b58dd5c31627cbb374183adb5fe0328739bbebda8c6907ab7f9153085c45d612e51c91ad3223cc10694c9c36a00f69c303c5865d3b022f2769353884056a91b2 SHA512 b8c9438a451ed9a52a66dc04e2bea841aaa9403a2fd266e7042555f93a159ced76061233220eb6fac0f106cea08835c13ef008b2432f6d658689e0fa8ee563e6
DIST snes9x-1.57.tar.gz 2959157 BLAKE2B 6307976247eb3a3bcb506028d75d9054ea853db5c629870a89832fd93ee2fe256799b9191922c67fcd8ef1ed2344d16326212001661c5038a88f290346b9f35c SHA512 d17ec45eeae8f57c618a51243ac54bc3a2a3f09632e4e50c51781cf8557362dbfa7856d9d4ecdebeea344041c2686e2256f6bcd2dcc71660fcf336cf887dcb1c
diff --git a/games-emulation/snes9x/metadata.xml b/games-emulation/snes9x/metadata.xml
index 197a5fc2e9d4..7bbb65b9c765 100644
--- a/games-emulation/snes9x/metadata.xml
+++ b/games-emulation/snes9x/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="netplay">Enable playing ROMs over the network (not recommended)</flag>
- <flag name="xrandr">Enable support for the X xrandr extension</flag>
</use>
<upstream>
<remote-id type="google-code">snes9x-gtk</remote-id>
diff --git a/games-emulation/snes9x/snes9x-1.55.ebuild b/games-emulation/snes9x/snes9x-1.55.ebuild
deleted file mode 100644
index 639a39ffc5c6..000000000000
--- a/games-emulation/snes9x/snes9x-1.55.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic gnome2-utils xdg-utils
-
-DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
-HOMEPAGE="https://github.com/snes9xgit/snes9x"
-SRC_URI="https://github.com/snes9xgit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
-IUSE="alsa debug gtk joystick multilib netplay nls opengl oss png pulseaudio portaudio +xv +xrandr"
-RESTRICT="bindist"
-
-RDEPEND="
- sys-libs/zlib:=[minizip]
- x11-libs/libX11
- x11-libs/libXext
- png? ( media-libs/libpng:0= )
- gtk? (
- >=x11-libs/gtk+-2.10:2
- x11-misc/xdg-utils
- portaudio? ( >=media-libs/portaudio-19_pre )
- joystick? ( >=media-libs/libsdl-1.2.12[joystick] )
- opengl? ( virtual/opengl )
- xv? ( x11-libs/libXv )
- xrandr? ( x11-libs/libXrandr )
- alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
- nls? ( dev-util/intltool )"
-
-S="${WORKDIR}/${P}/unix"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.53-cross-compile.patch
- "${FILESDIR}"/${PN}-1.55-build-system.patch
-)
-
-src_prepare() {
- cd "${WORKDIR}"/${P} || die
- rm -r unzip || die
- default
- cd unix || die
- eautoreconf
- if use gtk; then
- cd ../gtk || die
- eautoreconf
- fi
-}
-
-src_configure() {
- append-ldflags -Wl,-z,noexecstack
-
- # build breaks when zlib/zip support is disabled
- econf \
- --enable-gzip \
- --enable-zip \
- --with-system-zip \
- $(use_enable joystick gamepad) \
- $(use_enable debug debugger) \
- $(use_enable netplay) \
- $(use_enable png screenshot)
-
- if use gtk; then
- cd ../gtk || die
- econf \
- --with-zlib \
- --with-system-zip \
- $(use_enable nls) \
- $(use_with opengl) \
- $(use_with joystick) \
- $(use_with xv) \
- $(use_with xrandr) \
- $(use_with netplay) \
- $(use_with alsa) \
- $(use_with oss) \
- $(use_with pulseaudio) \
- $(use_with portaudio) \
- $(use_with png screenshot)
- fi
-}
-
-src_compile() {
- emake
- use gtk && emake -C ../gtk
-}
-
-src_install() {
- dobin ${PN}
-
- dodoc ../docs/{snes9x.conf.default,{changes,control-inputs,controls,snapshots}.txt}
-
- if use gtk; then
- emake -C ../gtk DESTDIR="${D}" install
- dodoc ../gtk/{AUTHORS,doc/README}
- fi
-
- docinto html
- dodoc {.,..}/docs/*.html
-}
-
-pkg_preinst() {
- use gtk && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- if use gtk ; then
- gnome2_icon_cache_update
- xdg_desktop_database_update
- fi
-}
-
-pkg_postrm() {
- if use gtk ; then
- gnome2_icon_cache_update
- xdg_desktop_database_update
- fi
-}