summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ethercard-diag/ethercard-diag-20050321.1g-r1.ebuild5
-rw-r--r--net-misc/ethercard-diag/ethercard-diag-20050321.1g.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/net-misc/ethercard-diag/ethercard-diag-20050321.1g-r1.ebuild b/net-misc/ethercard-diag/ethercard-diag-20050321.1g-r1.ebuild
index 91437c74edb9..4debc7d816be 100644
--- a/net-misc/ethercard-diag/ethercard-diag-20050321.1g-r1.ebuild
+++ b/net-misc/ethercard-diag/ethercard-diag-20050321.1g-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
inherit toolchain-funcs
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="!sys-apps/nictools"
src_prepare() {
+ default
# Since the binary is `ether-wake`, make sure the man page is
# `man ether-wake` and not `man etherwake`. #439504
sed -i \
@@ -29,5 +30,5 @@ src_prepare() {
src_compile() {
tc-export CC AR
- emake
+ default
}
diff --git a/net-misc/ethercard-diag/ethercard-diag-20050321.1g.ebuild b/net-misc/ethercard-diag/ethercard-diag-20050321.1g.ebuild
index c9013e391d21..06a430452f76 100644
--- a/net-misc/ethercard-diag/ethercard-diag-20050321.1g.ebuild
+++ b/net-misc/ethercard-diag/ethercard-diag-20050321.1g.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI="6"
+
inherit toolchain-funcs
DESCRIPTION="low level mii diagnostic tools including mii-diag and etherwake (merge of netdiag/isa-diag)"
@@ -17,11 +19,11 @@ DEPEND="!sys-apps/nictools"
src_compile() {
tc-export CC AR
- emake || die
+ default
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
dodir /sbin
- mv "${D}"/usr/sbin/{mii-diag,ether-wake} "${D}"/sbin/ || die
+ mv "${ED%/}"/usr/sbin/{mii-diag,ether-wake} "${ED%/}"/sbin/ || die
}