summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xsettingsd/Manifest1
-rw-r--r--x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xsettingsd/Manifest b/x11-misc/xsettingsd/Manifest
index 1e69a6779b63..78a93f23a594 100644
--- a/x11-misc/xsettingsd/Manifest
+++ b/x11-misc/xsettingsd/Manifest
@@ -1 +1,2 @@
DIST xsettingsd-1.0.0.tar.gz 23627 BLAKE2B e9f7dcb9fd017f34ed88f29e1954e0824764db66eac5fbcfa55e7edef51c4bdec1cb9383efe0b6cb18b88c04818b106b9c4f95fb25daaf09a76b4b4ef4e0b75f SHA512 39077050a2fc3206c308ba399328719303884dd668b61f7756f0a3a4388ed25a3cda0849a713126c22c6b80466ab74c1317fdd9cb3e652169c80c54ba0a45790
+DIST xsettingsd-1.0.2.tar.gz 22481 BLAKE2B 1f7e8112b8910ea20492109ebc2df90d7113804653d5758bbac2b52116e737505026ddd0e17b5444951ad83606ba41495ce8e165bbe04573c740cc3faee75c1b SHA512 da2a82d0b3f5061a1fad7632d800539f4e81bd3f8631dd724705d0601556c044c62da7469a974cbe8f6d8e070247493ac5776bac966cf36f1fae825562457baa
diff --git a/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild b/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild
new file mode 100644
index 000000000000..127a824fb368
--- /dev/null
+++ b/x11-misc/xsettingsd/xsettingsd-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Provides settings to X11 applications via the XSETTINGS specification"
+HOMEPAGE="https://github.com/derat/xsettingsd"
+SRC_URI="https://github.com/derat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND=">=dev-util/cmake-3.15"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package test GTest)
+ )
+ cmake_src_configure
+}