summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask-themes/Manifest1
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3_p20180112.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/flask-themes/Manifest b/dev-python/flask-themes/Manifest
index 99e208b34453..d4c057b1911b 100644
--- a/dev-python/flask-themes/Manifest
+++ b/dev-python/flask-themes/Manifest
@@ -1 +1,2 @@
DIST Flask-Themes-0.1.3.tar.gz 9723 BLAKE2B c141363ddcd4d0fa510845fcece4aedf831fed6c1ffac8a6b625265165bce77193ba6240bf5acc9ba990b914d88dabccb76871ac62eff629886348c3b4c7a382 SHA512 baf609b8b08446dda5b5d6d39bc0a2e7406f9270d70924c795243384be8967c82f82adcebe5e060352a0c33b763d600eeb5600d3116c10bdbbb3ceddfadf764a
+DIST flask-themes-0.1.3_p20180112.tar.gz 35526 BLAKE2B 71c606b8d0f2d2edf65594904c2ae11ca9236bb9386452592dae347293803e6c613cb2223e92e58f4b8a4e3b20365b17520889d173cd0ceb2255f849ea216ee8 SHA512 e7adbf309b07690906700608963f2cc8dd0fffb3edb061a10dae3b9d40f9ba6c6a56661ae47d34d808798d4ed168376c32642b47cbbab186d587bbedf1eba722
diff --git a/dev-python/flask-themes/flask-themes-0.1.3_p20180112.ebuild b/dev-python/flask-themes/flask-themes-0.1.3_p20180112.ebuild
new file mode 100644
index 000000000000..c0e38edd02a2
--- /dev/null
+++ b/dev-python/flask-themes/flask-themes-0.1.3_p20180112.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+MY_COMMIT="9eac2dcc9b81c3af29c2386ce1afba9b446562bf"
+
+DESCRIPTION="Infrastructure for theming support in Flask applications"
+HOMEPAGE="https://pythonhosted.org/Flask-Themes/"
+# https://github.com/maxcountryman/flask-themes/issues/8
+SRC_URI="https://github.com/maxcountryman/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/flask-0.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# No need to depend on dev-python/flask-sphinx-themes,
+# it is bundled in docs/_themes
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "Tests failed under ${EPYTHON}"
+}