summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/mpv/metadata.xml1
-rw-r--r--media-video/mpv/mpv-9999.ebuild9
2 files changed, 9 insertions, 1 deletions
diff --git a/media-video/mpv/metadata.xml b/media-video/mpv/metadata.xml
index df0200d2936c..1eb1494cbbc8 100644
--- a/media-video/mpv/metadata.xml
+++ b/media-video/mpv/metadata.xml
@@ -33,6 +33,7 @@
(Note: these outputs exist for compatibility reasons only, avoid if possible)</flag>
<flag name="tools">Install extra tools: mpv_identify.sh, mpv_idet.sh, and umpv</flag>
<flag name="uchardet">Enable subtitles charset discovery via <pkg>app-i18n/uchardet</pkg></flag>
+ <flag name="vulkan">Enable support for various Vulkan-based video backends</flag>
</use>
<upstream>
<remote-id type="github">mpv-player/mpv</remote-id>
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 8601e37b4bdf..f99a57b4a267 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -31,7 +31,7 @@ SLOT="0"
IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda doc drm dvb
dvd +egl gbm +iconv jack javascript jpeg lcms +libass libav libcaca libmpv
+lua luajit openal +opengl oss pulseaudio raspberry-pi rubberband samba sdl
- selinux test tools +uchardet v4l vaapi vdpau wayland +X +xv zlib
+ selinux test tools +uchardet v4l vaapi vdpau vulkan wayland +X +xv zlib
zsh-completion"
REQUIRED_USE="
@@ -50,6 +50,7 @@ REQUIRED_USE="
v4l? ( || ( alsa oss ) )
vaapi? ( || ( gbm X wayland ) )
vdpau? ( X )
+ vulkan? ( || ( X wayland ) )
wayland? ( egl )
X? ( egl? ( opengl ) )
xv? ( X )
@@ -96,6 +97,10 @@ COMMON_DEPEND="
v4l? ( media-libs/libv4l )
vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
+ vulkan? (
+ media-libs/shaderc
+ media-libs/vulkan-loader[X?,wayland?]
+ )
wayland? (
>=dev-libs/wayland-1.6.0
>=dev-libs/wayland-protocols-1.14
@@ -231,10 +236,12 @@ src_configure() {
$(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
$(use_enable libcaca caca)
$(use_enable jpeg)
+ $(use_enable vulkan shaderc)
$(use_enable raspberry-pi rpi)
$(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
--disable-mali-fbdev # Only available in overlays.
$(usex opengl '' '--disable-gl')
+ $(use_enable vulkan)
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.