summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/requests/requests-2.22.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/requests/requests-2.22.0.ebuild b/dev-python/requests/requests-2.22.0.ebuild
index b6aeadd10964..c708393872e8 100644
--- a/dev-python/requests/requests-2.22.0.ebuild
+++ b/dev-python/requests/requests-2.22.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -36,10 +36,12 @@ BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ ' python{2_7,3_{5,6,7}})
)
"
@@ -62,6 +64,8 @@ src_prepare() {
python_test() {
# tests hang with pypy & pypy3
[[ ${EPYTHON} == pypy* ]] && continue
+ # TODO: reenable when deps are ready
+ [[ ${EPYTHON} == python3_8 ]] && continue
pytest -vv || die "Tests failed with ${EPYTHON}"
}