summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch15
-rw-r--r--dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch15
-rw-r--r--dev-python/joblib/joblib-1.3.2.ebuild60
4 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index f54e2992b3dd..056cbffc9899 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,2 +1 @@
-DIST joblib-1.3.2.tar.gz 1987720 BLAKE2B f16235ead3ef0172a1e0dc2abad44967b029196f6c8c7a7e0c64283cac80e2b942ebfc2df5fa975bc152f574db023a9705f48b38855a11878e5c21e04cf7d831 SHA512 9b5acba1321351cf2ae548161ced18774b8b316aaf883cc8e77bf58898d1913361a3845d64f1f1f87e4e2394eafd92e0a6a8d67947db0c9a95a40e5f579baae6
DIST joblib-1.4.0.tar.gz 2115863 BLAKE2B cd61f3523ee697382db601ebb460aa6f4cd35947978fb07473c5e2e5337713a05aee8339acee211be0076d84a00174c37623cd6010b492aee84337abc2e5e633 SHA512 5c7e5475347906cdc8575eac8d2052470408c4ed5267d59a88a9d3126fb72b977d20b24fb0983b070e2f3c101e7da000fc03231733fef62531f9aeffacc47baf
diff --git a/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch b/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch
deleted file mode 100644
index a9865e00380e..000000000000
--- a/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/joblib/_utils.py b/joblib/_utils.py
-index 7693310e0..6cd99ad31 100644
---- a/joblib/_utils.py
-+++ b/joblib/_utils.py
-@@ -35,8 +35,8 @@ def eval_expr(expr):
-
-
- def eval_(node):
-- if isinstance(node, ast.Num): # <number>
-- return node.n
-+ if isinstance(node, ast.Constant): # <constant>
-+ return node.value
- elif isinstance(node, ast.BinOp): # <left> <operator> <right>
- return operators[type(node.op)](eval_(node.left), eval_(node.right))
- elif isinstance(node, ast.UnaryOp): # <operator> <operand> e.g., -1
diff --git a/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch b/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch
deleted file mode 100644
index 4d5a28815e4a..000000000000
--- a/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/joblib/test/test_parallel.py b/joblib/test/test_parallel.py
-index 906d436..c4a727c 100644
---- a/joblib/test/test_parallel.py
-+++ b/joblib/test/test_parallel.py
-@@ -189,6 +189,10 @@ def test_main_thread_renamed_no_warning(backend, monkeypatch):
- # warninfo catches Warnings from worker timeouts. We remove it if it exists
- warninfo = [w for w in warninfo if "worker timeout" not in str(w.message)]
-
-+ # We don't want to count DeprecationWarnings
-+ warninfo = [w for w in warninfo
-+ if not isinstance(w.message, DeprecationWarning)]
-+
- # The multiprocessing backend will raise a warning when detecting that is
- # started from the non-main thread. Let's check that there is no false
- # positive because of the name change.
diff --git a/dev-python/joblib/joblib-1.3.2.ebuild b/dev-python/joblib/joblib-1.3.2.ebuild
deleted file mode 100644
index eacb811bfeb7..000000000000
--- a/dev-python/joblib/joblib-1.3.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="
- https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib/
- https://pypi.org/project/joblib/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/loky[${PYTHON_USEDEP}]
-"
-# joblib is imported by setup.py so we need ${RDEPEND}
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Borrowed from Fedora: https://github.com/joblib/joblib/issues/1478
- "${FILESDIR}/${P}-py3.12-no-depr-warn.patch"
- # https://github.com/joblib/joblib/pull/1518
- "${FILESDIR}/${P}-py3.12-avoid-ast.num-and-node.n.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # https://github.com/joblib/joblib/issues/1115
- joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
- # unexpectedly pickleable?
- joblib/test/test_hashing.py::test_hashing_pickling_error
-)
-
-python_prepare_all() {
- # unbundle
- rm -r joblib/externals || die
- sed -e "/joblib.externals/d" -i pyproject.toml || die
- find -name '*.py' -exec \
- sed -e 's:\(joblib\)\?\.externals\.::' \
- -e 's:from \.externals ::' \
- -i {} + || die
-
- distutils-r1_python_prepare_all
-}