summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libtommath/libtommath-1.2.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/libtommath/libtommath-1.2.0.ebuild b/dev-libs/libtommath/libtommath-1.2.0.ebuild
index 78def9854c3f..56b357a35051 100644
--- a/dev-libs/libtommath/libtommath-1.2.0.ebuild
+++ b/dev-libs/libtommath/libtommath-1.2.0.ebuild
@@ -65,6 +65,11 @@ src_test() {
src_install() {
_emake -f makefile.shared install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local path="usr/$(get_libdir)/libtommath.${PV}.dylib"
+ install_name_tool -id "${EPREFIX}/${path}" "${ED}/${path}" || die "Failed to adjust install_name"
+ fi
+
# We only link against -lc, so drop the .la file.
find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then