summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index c7075058cd86..c0e39161e8cc 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,3 +1,4 @@
DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
DIST snakeoil-0.8.3.tar.gz 297775 BLAKE2B b08c2c1bfea98e391b1da59ba0fd28e2187a83291c9c665f1394ed2b985b959ff5f5328db6a379d0d29e0fd86c82f965c40280f38ef5064727d4d9b173905c42 SHA512 d17a410f1684bb0398a115bbe6539895ea84a2ff7a1f3d05a66937f5f83783f2c503e985839d26f03565e960040a10e1985c43bb7376feda7c088ae279838be9
DIST snakeoil-0.8.4.tar.gz 297551 BLAKE2B 1c79805c65a9bec5f392e7c43dd36a9d085fb4f58371137e6fe1a5a72fd57b665c69f534175fef76aae3ae185a85343115671acdd58d214733c5b057468c8e54 SHA512 7a074d37b8a14260a0123acb63d16a2c004ec59a132ecccf3f528cac754e02661b766b0169646c8cc7743d7401160b3d7d469806e3da5b055d2352edb8bcdc68
+DIST snakeoil-0.8.5.tar.gz 296311 BLAKE2B d88b3f5fe299511343676ffad5a1f1efd10078f50d029b74feea66f6b6f65897e2d4dac2e96f65e0cbaae0942c5b9867fce868adf12be746c9c4ebf6f6a7f52f SHA512 d25cbc105d5c881d8e99d5c2970d524914838917a4a716d8f7269a85af0d9a067b9bb9c26a37b9eb49239f97360938bece1a1ebe87aba04340b0fe528f44dc4b
diff --git a/dev-python/snakeoil/snakeoil-0.8.5.ebuild b/dev-python/snakeoil/snakeoil-0.8.5.ebuild
new file mode 100644
index 000000000000..e073443aa4a6
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.8.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}