summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/xonotic/Manifest1
-rw-r--r--games-fps/xonotic/xonotic-0.8.2.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index 79b609af77e1..a18db6cb7b8e 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1 +1,2 @@
DIST xonotic-0.8.1.zip 984854761 SHA256 be8bcc41e2993a2f26d4d04c65a7eab810443bd98b11b45e482ffdbbf284c46f SHA512 adfce546257bdc7cfebe94f53eaa9cc9b19eaa546c6405e31ed6af080e3948732c960a024126202e5853cb98b955daadeeb5a96c602a6d4d83e284d3540214a4 WHIRLPOOL 4359263c98352a8b5d169147d9bfecb4258628f212d9a965f0d1577d0a8b2469648ae1ce21d8dc0ff622d20e126ea52e1464363f69fcf514991aefad71c1bee7
+DIST xonotic-0.8.2.zip 991045679 SHA256 a22f7230f486c5825b55cfdadd73399c9b0fae98c9e081dd8ac76eca08359ad5 SHA512 0787fcf326827ae0292e5917c7ff2c7fd79947209d4b62e7f83b8b828bec15b575da304e0631f9f163c9b0bd93bed13616e142398ff08cbdaaea890a939dfca5 WHIRLPOOL aff99ae1e995265c832747923afb5ee1048719d4410cc6b55ec773e51dc0920acffe627541209b5450f572e78ef7c74c8822ae2f6ebec2a8888f80dbfd34afba
diff --git a/games-fps/xonotic/xonotic-0.8.2.ebuild b/games-fps/xonotic/xonotic-0.8.2.ebuild
new file mode 100644
index 000000000000..cd06a49ba1c7
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.8.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils check-reqs toolchain-funcs
+
+# Switch to ^ when we switch to EAPI=6.
+MY_PN="X${PN:1}"
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="http://www.xonotic.org/"
+SRC_URI="http://dl.xonotic.org/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dedicated doc ode sdl"
+
+UIRDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/libmodplug
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ virtual/opengl
+ media-libs/freetype:2
+ alsa? ( media-libs/alsa-lib )
+ ode? ( dev-games/ode[double-precision] )
+ sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
+UIDEPEND="
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0
+ media-libs/libpng:0
+ net-misc/curl
+ ~dev-libs/d0_blind_id-1.0
+ !dedicated? ( ${UIRDEPEND} )"
+DEPEND="${RDEPEND}
+ !dedicated? ( ${UIDEPEND} )"
+
+CHECKREQS_DISK_BUILD="1200M"
+CHECKREQS_DISK_USR="950M"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ check-reqs_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^EXE_/s:darkplaces:${PN}:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e '/^STRIP/s/strip/true/' \
+ source/darkplaces/makefile.inc || die
+
+ if ! use alsa; then
+ sed -i \
+ -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
+ source/darkplaces/makefile || die
+ fi
+}
+
+src_compile() {
+ local t="$(usex debug debug release)"
+ local i
+
+ tc-export CC CXX LD AR RANLIB
+
+ # use a for-loop wrt bug 473352
+ for i in sv-${t} $(usex !dedicated "cl-${t} $(usex sdl "sdl-${t}" "")" "") ; do
+ emake \
+ -C source/darkplaces \
+ DP_LINK_ODE=$(usex ode shared no) \
+ DP_FS_BASEDIR="/usr/${PN}" \
+ ${i}
+ done
+}
+
+src_install() {
+ if ! use dedicated; then
+ dobin source/darkplaces/${PN}-glx
+ newicon misc/logos/${PN}_icon.svg ${PN}.svg
+ make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
+
+ if use sdl; then
+ dobin source/darkplaces/${PN}-sdl
+ make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
+ fi
+ fi
+ dobin source/darkplaces/${PN}-dedicated
+
+ dodoc Docs/*.txt
+ use doc && dohtml -r Docs
+
+ insinto "/usr/${PN}"
+ doins -r key_0.d0pk server data
+}
+
+pkg_postinst() {
+ elog "If you are using opensource drivers you should consider installing: "
+ elog " media-libs/libtxc_dxtn"
+}