summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-go/go-crypto/Manifest1
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20160126.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-go/go-crypto/Manifest b/dev-go/go-crypto/Manifest
index c6220f177ef4..8f6651221224 100644
--- a/dev-go/go-crypto/Manifest
+++ b/dev-go/go-crypto/Manifest
@@ -1,2 +1 @@
-DIST go-crypto-0_pre20160126.tar.gz 902001 BLAKE2B 54d38a9aea69e01485417cbf8a900135730dca4bc79c9d5d1187eadb11a8dfca9ef6e72056c4ed4ad4a34b172379d94e6beb82ece9031411b8aa12af85200fb2 SHA512 168129ab9581b7348fb3285e045d99a0a837ac7bd65bf9f5e7a220fffbb9e2abf76da5f521c66eea7179eba0ad8da68d6f41cd9624ea40a9da25a18838427846
DIST go-crypto-0_pre20180816.tar.gz 1637516 BLAKE2B 800787412e1e52f70bc3df5b1b638e86ed2c66de86522786d7e3d8959f18d02426270d1f577ebaa8077d7d98c84ca7a358bed951c862a44b9293de8edebb17b4 SHA512 d2b730ba75b49b96f35969802b7321cd2efc89dcd2e8c0b8eaca545cb18287b34ad1c9ecbd07c6b4ace8708575d4586fbe1139d032a7038cc7221ad010d08074
diff --git a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
deleted file mode 100644
index 159900040323..000000000000
--- a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-EGO_PN=golang.org/x/crypto/...
-EGO_SRC=golang.org/x/crypto
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="1f22c0103821b9390939b6776727195525381532"
- SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go supplementary cryptography libraries"
-HOMEPAGE="https://godoc.org/golang.org/x/crypto"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- # disable broken tests
- sed -e 's:TestAgentForward(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
- sed -e 's:TestRunCommandSuccess(:_\0:' \
- -e 's:TestRunCommandStdin(:_\0:' \
- -e 's:TestRunCommandStdinError(:_\0:' \
- -e 's:TestRunCommandWeClosed(:_\0:' \
- -e 's:TestFuncLargeRead(:_\0:' \
- -e 's:TestKeyChange(:_\0:' \
- -e 's:TestValidTerminalMode(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/session_test.go || die
-}
-
-src_compile() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- rm -rf "${T}/goroot/src/${EGO_SRC}" || die
- rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
- export GOROOT="${T}/goroot"
- # Exclude $(get_golibdir_gopath) from GOPATH, for bug 577908 which may
- # or may not manifest, depending on what libraries are installed.
- export GOPATH="${WORKDIR}/${P}"
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_test() {
- # Exclude $(get_golibdir_gopath) from GOPATH
- go test -v -work -x "${EGO_PN}" || die
-}