summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/certbot/certbot-0.8.1-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/certbot/certbot-0.8.1-r1.ebuild b/app-crypt/certbot/certbot-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..3f4ec97a0b33
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.8.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ =app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/pythondialog-3.2.2:python-2' python2_7)
+ dev-python/mock[${PYTHON_USEDEP}]"
+ # for when py3 support is added
+ # $(python_gen_cond_dep '>=dev-python/pythondialog-3.2.2:0' python3_*)
+DEPEND="
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/astroid-1.3.5
+ dev-python/coverage
+ dev-python/nose
+ dev-python/pep8
+ >=dev-python/psutil-2.2.1
+ >=dev-python/pylint-1.4.2
+ dev-python/wheel
+ )"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}