summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.33.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 2cbd9afd6e35..eb2cf6a288e0 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -2,3 +2,4 @@ DIST python-zeroconf-0.30.0.gh.tar.gz 64301 BLAKE2B ea0d5e36f3f012f217cbd4eeff0a
DIST python-zeroconf-0.32.0.gh.tar.gz 115276 BLAKE2B 7084c02f989ebc6db6686b82ce3212158595b87e00567e4857e84790a30a2fa6f688288769d1eb118da485a6755da1ef404765070d26905d10ab45b1d95ca849 SHA512 6a612b39be85e673cffc560ea5bcc16facc5a16a370ff6edb1d4f7ff978a01d6ba249a9b313caca3b3ed0c6463a4914a98063eb89f28268cec1c9a2faa4db611
DIST python-zeroconf-0.32.1.gh.tar.gz 116507 BLAKE2B 03de415620745b75cd43be74b724faf909aad9628175f18cf4b2c04245d02adbca984eaa861e807729f36caa3feecab913f2e4aafcdd9aac1af02de6eeefbb3d SHA512 cefcd1abdc3ca2b5ed796aee09e6826c0d0f54343bdefbf45c425d6e033542dc061c84fb4438ba53774d87c6516801c6e2196c1e6cfdd9dbf9187f5d8d4b1b11
DIST python-zeroconf-0.33.0.gh.tar.gz 118002 BLAKE2B e5bdf8011777f46207c7f0aafbf4bfc34e704b59e01fcecd93e2ca05154f836bbe206688242eb37578a0e3b6d462de86944bdc81b96b0f3613eed21e9d0b6be0 SHA512 214fc1b25e1b900b6745f808144c0a1d94102dbc30f1e6ae49dfbfe2e75e9611e33d1341d192641be363662a0259aa340f52fe20fcf2bd5cf1611e823754186d
+DIST python-zeroconf-0.33.2.gh.tar.gz 118266 BLAKE2B e239443c778d24895a830ac8d4f23be5eeac701b92ddf945efc955a731cbce62bea10243f57a0929ad21c4444d32c37b0a9e23b53e734362b9c6b9ce85e2eb59 SHA512 9631dc348baf028794934d826a1fd2e874cf9039e6fb1c93a1b9a8e2a95ae436ab2fc1a955e2d89656c37a56b71075b578857f6de041a7e61ff55c7a62a2a7a3
diff --git a/dev-python/zeroconf/zeroconf-0.33.2.ebuild b/dev-python/zeroconf/zeroconf-0.33.2.ebuild
new file mode 100644
index 000000000000..0e1b2943b16e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.33.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect }
+}