summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/setools/Manifest3
-rw-r--r--app-admin/setools/setools-3.3.8-r7.ebuild141
-rw-r--r--app-admin/setools/setools-4.0.1.ebuild52
3 files changed, 0 insertions, 196 deletions
diff --git a/app-admin/setools/Manifest b/app-admin/setools/Manifest
index 9d1c3ae28828..470bc7c3df5b 100644
--- a/app-admin/setools/Manifest
+++ b/app-admin/setools/Manifest
@@ -1,4 +1 @@
-DIST setools-3.3.8-04-gentoo-patches.tar.bz2 94986 BLAKE2B e502d44d277572be660871794afb0a58655e65d445e3c6d5f06ff5cadf4be29b95a0c19e5faa21f46919da99b4efecf1404ac91f3d6671165ad5426858d1aaac SHA512 39bf00b6aaf31821c6e2e2fb4c460dd1914fba4bf8385acebedf88f1533da990f1fb925dd49d75827aebef3f394a50a1edea46a07204193b58c65a066a064e6a
-DIST setools-3.3.8.tar.bz2 951428 BLAKE2B b3d78bd4e40d6d695dfbf670ff952ecdec2c9654ade3b0bba99b5afe240456d846782c001f63cc31ea93c72b3a7a632949da6fc86632ae7d217987e1d353eb38 SHA512 2c42ee9904174ed6c6fc129e374ec3591925094ab0ef65001b0104e365c5634bf4a79f28369608c80199d8f59fafaa5f274107c04c129c380eeef7adb0c32667
-DIST setools-4.0.1.tar.gz 399888 BLAKE2B 688a5ed18b197391b43a89375818b50b47dda5834a81a8c4b05d0f3c4a9c232ae9663c8135e46b8ce038df0c14b2e9eb93068333dce177b952741249e84d45d2 SHA512 d0a36cfddc6a6f47ecaa8402141271558e97467b6c449d18b98bf6fe894189f29a32fb672e3ff573efdb44964bd361283c68c2906d02f8a9c1269b6b71903bc2
DIST setools-4.1.1.tar.gz 461649 BLAKE2B a753718aa6a5de889ba7a2eea921340061edf1bcb0b572a365e858949a92d2f8a92a876be2e4bc539d85fa6029511ab6afabfbe8138cdb5a73b587a9b58551bb SHA512 2e55a3b07e2f94d7c84054f31d266567b9acc708fe2b0e16ac3ea24e8301c712bcf564ff915a6135a1a6ba6822682bb3a6530dae20161a832fb7048364acbd04
diff --git a/app-admin/setools/setools-3.3.8-r7.ebuild b/app-admin/setools/setools-3.3.8-r7.ebuild
deleted file mode 100644
index 3240c25b84d5..000000000000
--- a/app-admin/setools/setools-3.3.8-r7.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit autotools java-pkg-opt-2 python-r1 eutils toolchain-funcs
-
-DESCRIPTION="SELinux policy tools"
-HOMEPAGE="https://github.com/TresysTechnology/setools/wiki"
-SRC_URI="http://oss.tresys.com/projects/setools/chrome/site/dists/${P}/${P}.tar.bz2
- https://dev.gentoo.org/~perfinion/patches/setools/${P}-04-gentoo-patches.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
-IUSE="X debug java python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMONDEPEND=">=sys-libs/libsepol-2.4
- >=sys-libs/libselinux-2.4
- >=dev-db/sqlite-3.2:3
- dev-libs/libxml2:2
- python? ( ${PYTHON_DEPS} )
- X? (
- >=dev-lang/tk-8.4.9:0=
- >=gnome-base/libglade-2.0
- >=x11-libs/gtk+-2.8:2
- )"
-
-DEPEND="${COMMONDEPEND}
- >=sys-devel/automake-1.12.1
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- java? ( dev-lang/swig
- virtual/jdk:= )
- python? ( dev-lang/swig )"
-
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.4:= )
- X? ( >=dev-tcltk/bwidget-1.8 )"
-
-RESTRICT="test"
-# setools dirs that contain python code to build
-PYTHON_DIRS="libapol/swig/python libpoldiff/swig/python libqpol/swig/python libseaudit/swig/python libsefs/swig/python python"
-
-pkg_setup() {
- if use java; then
- java-pkg-opt-2_pkg_setup
- fi
-}
-
-src_prepare() {
- EPATCH_MULTI_MSG="Applying various (Gentoo) setool fixes... " \
- EPATCH_SUFFIX="patch" \
- EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
- EPATCH_FORCE="yes" \
- epatch
-
- epatch "${FILESDIR}"/${PN}-3.3.8-no-check-file.patch
- epatch "${FILESDIR}"/${PN}-3.3.8-policy-max.patch
-
- # Fix build failure due to double __init__.py installation
- sed -e "s/^wrappedpy_DATA = qpol.py \$(pkgpython_PYTHON)/wrappedpy_DATA = qpol.py/" -i libqpol/swig/python/Makefile.am || die
- # Disable broken check for SWIG version. Bug #542032
- sed -e "s/AC_PROG_SWIG(2.0.0)/AC_PROG_SWIG/" -i configure.ac || die "sed failed"
-
- local dir
- for dir in ${PYTHON_DIRS}; do
- # Python bindings are built/installed manually.
- sed -e "s/MAYBE_PYSWIG = python/MAYBE_PYSWIG =/" -i ${dir%python}Makefile.am || die "sed failed"
- # Make PYTHON_LDFLAGS replaceable during running `make`.
- sed -e "/^AM_LDFLAGS =/s/@PYTHON_LDFLAGS@/\$(PYTHON_LDFLAGS)/" -i ${dir}/Makefile.am || die "sed failed"
- done
-
- epatch_user
-
- eautoreconf
-
- # Disable byte-compilation of Python modules.
- echo '#!/bin/sh' > py-compile
-}
-
-src_configure() {
- tc-ld-disable-gold #467136
- econf \
- --with-java-prefix=${JAVA_HOME} \
- --disable-selinux-check \
- --disable-bwidget-check \
- $(use_enable python swig-python) \
- $(use_enable java swig-java) \
- $(use_enable X swig-tcl) \
- $(use_enable X gui) \
- $(use_enable debug)
-
- # work around swig c99 issues. it does not require
- # c99 anyway.
- sed -i -e 's/-std=gnu99//' "${S}/libseaudit/swig/python/Makefile"
-}
-
-src_compile() {
- emake
-
- if use python; then
- building() {
- python_export PYTHON_INCLUDEDIR
- python_export PYTHON_SITEDIR
- python_export PYTHON_LIBS
- emake \
- SWIG_PYTHON_CPPFLAGS="-I${PYTHON_INCLUDEDIR}" \
- PYTHON_LDFLAGS="${PYTHON_LIBS}" \
- pyexecdir="${PYTHON_SITEDIR}" \
- pythondir="${PYTHON_SITEDIR}" \
- -C "$1"
- }
- local dir
- for dir in ${PYTHON_DIRS}; do
- python_foreach_impl building ${dir}
- done
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use python; then
- installation() {
- python_export PYTHON_SITEDIR
- emake DESTDIR="${D}" \
- pyexecdir="${PYTHON_SITEDIR}" \
- pythondir="${PYTHON_SITEDIR}" \
- -C "$1" install
- }
-
- local dir
- for dir in ${PYTHON_DIRS}; do
- python_foreach_impl installation "${dir}"
- done
- fi
-}
diff --git a/app-admin/setools/setools-4.0.1.ebuild b/app-admin/setools/setools-4.0.1.ebuild
deleted file mode 100644
index 4f9175aaf823..000000000000
--- a/app-admin/setools/setools-4.0.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/TresysTechnology/setools/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/TresysTechnology/setools.git"
-else
- SRC_URI="https://github.com/TresysTechnology/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~mips x86"
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="X debug test"
-
-RDEPEND="${PYTHON_DEPS}
- >=sys-libs/libselinux-2.4:=[${PYTHON_USEDEP}]
- >=dev-python/networkx-1.8[${PYTHON_USEDEP}]
- app-arch/bzip2:=
- dev-libs/libpcre:=
- X? (
- dev-python/PyQt5
- )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2.0.12:0
- sys-devel/bison
- sys-devel/flex
- >=sys-libs/libsepol-2.5
- test? (
- python_targets_python2_7? ( dev-python/mock[${PYTHON_USEDEP}] )
- dev-python/tox[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
-
- use X || local PATCHES=( "${FILESDIR}"/setools-4.0.1-remove-gui.patch )
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}