summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/drawio-desktop-bin/Manifest3
-rw-r--r--app-office/drawio-desktop-bin/drawio-desktop-bin-22.1.16.ebuild113
-rw-r--r--app-office/drawio-desktop-bin/metadata.xml16
3 files changed, 132 insertions, 0 deletions
diff --git a/app-office/drawio-desktop-bin/Manifest b/app-office/drawio-desktop-bin/Manifest
new file mode 100644
index 000000000000..5f60ca57d501
--- /dev/null
+++ b/app-office/drawio-desktop-bin/Manifest
@@ -0,0 +1,3 @@
+DIST drawio-22.1.16-icon.svg 9345 BLAKE2B a3f4c3a77ebe14d141c5a2f03ac3c9bf7263b95f435dd8b6b8aacc0bcd1af1d659a2d0ccf565ee95ff3cd9c26dae72199c2ac0da2ae17656935b8e8972725335 SHA512 d226c8f2c5997de66fdf89830d8bce3a51e858c266be8877080e35927a22ebe0c67faaa087478b8370538046ecf1bff44c5eb46f2c369554651582cef2ed831e
+DIST drawio-desktop-bin-amd64-22.1.16.deb 135224132 BLAKE2B 92699617f5ce6d48b61d016abc2f3e700c12a818bc5e01e5fc7eac9a898c8f723bbd74a342cb60bb4f1ccdc444021f71461d1e9ac749631977da84380a577240 SHA512 97ebb05f01cc0ae455f9ede68cb2007528bac9750a6d4842e797addc2a12a94a4a2448e3ed66b16f27f1d3c468049d00e6d7b90062414d05211169079aefd3dc
+DIST drawio-desktop-bin-arm64-22.1.16.deb 130277246 BLAKE2B 3356e635471b3edc74533e1bb10854173a2bc6762243caef12b39265918563daa9687820068132863048b27f3d7b6c9657ed4e0c29c16572941c0d226c59b428 SHA512 cc810443975b819e020c0e31837a8c7751c197dfa9461f7757a589adace92b0799823f13b1f8d99b9f1de3cba973e937eaff92bd53ac343dd4f9b3426c519776
diff --git a/app-office/drawio-desktop-bin/drawio-desktop-bin-22.1.16.ebuild b/app-office/drawio-desktop-bin/drawio-desktop-bin-22.1.16.ebuild
new file mode 100644
index 000000000000..7eba866b60a7
--- /dev/null
+++ b/app-office/drawio-desktop-bin/drawio-desktop-bin-22.1.16.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he
+ hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
+ sv sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+RC_COMMIT="626bbfa94ad4e1e9806ef076b5cd5d426bcf4976"
+
+inherit chromium-2 desktop unpacker xdg
+
+DESCRIPTION="draw.io diagramming and whiteboarding desktop app"
+HOMEPAGE="https://www.drawio.com/"
+
+SRC_URI="
+ amd64? ( https://github.com/jgraph/drawio-desktop/releases/download/v${PV}/drawio-amd64-${PV}.deb
+ -> ${PN}-amd64-${PV}.deb )
+ arm64? ( https://github.com/jgraph/drawio-desktop/releases/download/v${PV}/drawio-arm64-${PV}.deb
+ -> ${PN}-arm64-${PV}.deb )
+ https://github.com/jgraph/drawio-desktop/blob/${RC_COMMIT}/build/icon.svg
+ -> drawio-${PV}-icon.svg
+"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+
+# These are the licenses used by node_modules packages, drawio and drawio-desktop repositories
+LICENSE="
+ 0BSD Apache-2.0 BSD BSD-2 CC0-1.0 GPL-2 ISC PYTHON WTFPL-2 MIT ZLIB
+"
+
+SLOT="0"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ >=dev-libs/nss-3
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/drawio/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/drawio/locales" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ #Fix mimetype
+ sed -i \
+ -e 's*<icon name="x-office-document" />*<icon name="application-vnd.jgraph.mxfile"/>*g' \
+ -e '4 i <sub-class-of type="text/xml"/>' \
+ "usr/share/mime/packages/drawio.xml" || die "couldn't modify drawio.xml"
+}
+
+src_install() {
+ local DESTDIR="/opt/drawio"
+
+ # Copy icons
+ local IC_SIZE
+ for IC_SIZE in 16 32 48 64 96 128 192 256 512 1024
+ do
+ newicon -s "${IC_SIZE}" "usr/share/icons/hicolor/${IC_SIZE}x${IC_SIZE}/apps/drawio.png" drawio.png
+ newicon -s "${IC_SIZE}" -c mimetypes "usr/share/icons/hicolor/${IC_SIZE}x${IC_SIZE}/apps/drawio.png" \
+ application-vnd.jgraph.mxfile.png
+ done
+ newicon -s scalable "${DISTDIR}/drawio-${PV}-icon.svg" drawio.svg
+ newicon -s scalable -c mimetypes "${DISTDIR}/drawio-${PV}-icon.svg" application-vnd.jgraph.mxfile.svg
+
+ # Create a desktop entry and associate it with the drawio mime type
+ domenu usr/share/applications/drawio.desktop
+
+ # MIME descriptor for .drawio and .vsdx files
+ insinto /usr/share/mime/packages
+ doins "usr/share/mime/packages/drawio.xml"
+
+ exeinto "${DESTDIR}"
+ doexe opt/drawio/chrome-sandbox opt/drawio/chrome_crashpad_handler opt/drawio/drawio opt/drawio/*.so*
+
+ insinto "${DESTDIR}"
+ insopts -m0644
+ doins opt/drawio/*.pak opt/drawio/*.bin opt/drawio/*.json opt/drawio/*.dat
+ insopts -m0755
+ doins -r opt/drawio/locales opt/drawio/resources
+
+ dosym "${DESTDIR}"/drawio /usr/bin/drawio
+}
diff --git a/app-office/drawio-desktop-bin/metadata.xml b/app-office/drawio-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..e55ac6ceb34b
--- /dev/null
+++ b/app-office/drawio-desktop-bin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jgraph/drawio-desktop</remote-id>
+ <bugs-to>https://github.com/jgraph/drawio-desktop/issues</bugs-to>
+ </upstream>
+</pkgmetadata>