summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/pry/Manifest2
-rw-r--r--dev-ruby/pry/pry-0.13.1.ebuild45
-rw-r--r--dev-ruby/pry/pry-0.14.0.ebuild45
3 files changed, 0 insertions, 92 deletions
diff --git a/dev-ruby/pry/Manifest b/dev-ruby/pry/Manifest
index 0fa146012e75..0eaac44be6b0 100644
--- a/dev-ruby/pry/Manifest
+++ b/dev-ruby/pry/Manifest
@@ -1,3 +1 @@
-DIST pry-0.13.1.tar.gz 240103 BLAKE2B da4797e36aecba8bf1a785738339ed4be1e06ab28b329b66551a908898cd0515fc0da2434ba96e9fa0f350c9d32c13f850660bc0236c6c0218a4bd3182ec4ced SHA512 bec52c75dce365db68504634b2eaf6b0f312527031401199fcdbaa3ec5a9272148239d93305f8e66c4d36513f9fec3fe045e978c5a10f012a2880ab4a16b7e85
-DIST pry-0.14.0.tar.gz 238895 BLAKE2B 325a7eaa03836cf78c8599af15aa6758bc36cccf20937c3a7f222a5a831d2ffd8fc990e005b587779fe2a15077e0b8b38628c6f075b2b73de7ea44b5642e8635 SHA512 c10ba16d7dbd05308079f98a68fbcbb367d07977fd71a7077a80938b10c7588f585651e046d29a2f1499f136f56c062598f77ada8fb47a31608a4ea8536c5ef8
DIST pry-0.14.1.tar.gz 239261 BLAKE2B 46bba71668cbfcb710ebf4f8921d1b4cbaad887b1546b4566a90f9f246f1ff41451ccabb4a8692bb8a404532227aaa72b2d530fa4451bf1b7141cb6f57dfea1a SHA512 b258d1ae7ffd82c6fbed7edbd6e9bc64006eb54e3376a2f85b7482e0517be34efb46a2264975820cac3b7c0bea89b855b4d2a6fb104ff760f25667e1afb3ba44
diff --git a/dev-ruby/pry/pry-0.13.1.ebuild b/dev-ruby/pry/pry-0.13.1.ebuild
deleted file mode 100644
index a6ccfb80e171..000000000000
--- a/dev-ruby/pry/pry-0.13.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
-HOMEPAGE="https://github.com/pry/pry/wiki"
-SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE=""
-SLOT="ruby19"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-ruby_add_rdepend "
- >=dev-ruby/coderay-1.1.0 =dev-ruby/coderay-1.1*
- =dev-ruby/method_source-1*"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/open4-1.3
- >=dev-ruby/rake-0.9
- >=dev-ruby/mocha-1.0
- )"
-
-all_ruby_prepare() {
- # Avoid unneeded dependency on git.
- # Loosen coderay dependency.
- sed -e '/git ls-files/d' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -e '/[Bb]undler/d' -i spec/spec_helper.rb || die
-
- # Skip integration tests because they depend to much on specifics of the environment.
- rm -f spec/integration/* || die
- sed -i -e '/loads files through repl and exits/askip "depends on parent directory"' spec/cli_spec.rb || die
-}
diff --git a/dev-ruby/pry/pry-0.14.0.ebuild b/dev-ruby/pry/pry-0.14.0.ebuild
deleted file mode 100644
index 8d4d5fc87dab..000000000000
--- a/dev-ruby/pry/pry-0.14.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
-HOMEPAGE="https://github.com/pry/pry/wiki"
-SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE=""
-SLOT="ruby19"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-ruby_add_rdepend "
- >=dev-ruby/coderay-1.1.0 =dev-ruby/coderay-1.1*
- =dev-ruby/method_source-1*"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/open4-1.3
- >=dev-ruby/rake-0.9
- >=dev-ruby/mocha-1.0
- )"
-
-all_ruby_prepare() {
- # Avoid unneeded dependency on git.
- # Loosen coderay dependency.
- sed -e '/git ls-files/d' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -e '/[Bb]undler/d' -i spec/spec_helper.rb || die
-
- # Skip integration tests because they depend to much on specifics of the environment.
- rm -f spec/integration/* || die
- sed -i -e '/loads files through repl and exits/askip "depends on parent directory"' spec/cli_spec.rb || die
-}