summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-metrics/fusioninventory-agent/Manifest1
-rw-r--r--app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild39
-rw-r--r--app-metrics/fusioninventory-agent/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/app-metrics/fusioninventory-agent/Manifest b/app-metrics/fusioninventory-agent/Manifest
new file mode 100644
index 000000000000..0b2878274ac1
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/Manifest
@@ -0,0 +1 @@
+DIST fusioninventory-agent-2.5.2.tar.gz 2728830 BLAKE2B c6a26c4adb6b8e6bdaf829e46dffa47cc629731411f8b6e55a17eb83bd69536ca0e07899c5e3536ee3962326e643157c60ab8825971b2f44995e42f04e689321 SHA512 5bd39652fd3b857a4364fa300b07b8a2580bdafc6b84f95ab852b60b887ce8278bd99f85b74991b6da5cc21e1636f33c7125dbc27a02df915df4ea6f0ceffaed
diff --git a/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild b/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild
new file mode 100644
index 000000000000..b5a7d0a0a611
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="The FusionInventory agent is a generic management agent"
+HOMEPAGE="http://fusioninventory.org/"
+SRC_URI="https://github.com/fusioninventory/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-perl/libwww-perl
+ dev-perl/File-Which
+ dev-perl/Net-IP
+ dev-perl/Text-Template
+ dev-perl/UNIVERSAL-require
+ dev-perl/XML-TreePP
+ virtual/perl-IO-Compress
+ dev-perl/HTTP-Daemon
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Proc-Daemon
+ "
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-perl/Module-Install
+ "
+
+src_prepare() {
+ sed -e 's:\$(PREFIX)/etc:/etc:g' \
+ -i Makefile.PL || die "sed failed"
+ default
+}
diff --git a/app-metrics/fusioninventory-agent/metadata.xml b/app-metrics/fusioninventory-agent/metadata.xml
new file mode 100644
index 000000000000..086586c08a88
--- /dev/null
+++ b/app-metrics/fusioninventory-agent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>