summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
index d2003e60dd12..c90d59c476c1 100644
--- a/games-action/xpilot/xpilot-4.5.5-r1.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
app-text/rman
x11-base/xorg-proto
x11-misc/gccmakedep
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
src_prepare() {
#default
@@ -38,12 +38,18 @@ src_prepare() {
src/client/textinterface.c || die
}
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+}
+
src_compile() {
- xmkmf || die
- emake Makefiles
- emake includes
- emake depend
- emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}"
+ emake \
+ AR="$(tc-getAR) cq" \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}"
}
src_install() {