summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch8
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild4
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild4
3 files changed, 16 insertions, 0 deletions
diff --git a/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch b/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch
new file mode 100644
index 000000000000..0d137416994d
--- /dev/null
+++ b/dev-haskell/wxhaskell/files/wxhaskell-0.13.2.3-ghc-7.10.patch
@@ -0,0 +1,8 @@
+diff --git a/src/Graphics/UI/WX/Window.hs b/src/Graphics/UI/WX/Window.hs
+index 0b04fa9..39c0505 100644
+--- a/src/Graphics/UI/WX/Window.hs
++++ b/src/Graphics/UI/WX/Window.hs
+@@ -1,2 +1,2 @@
+-{-# LANGUAGE TypeSynonymInstances, FlexibleInstances #-}
++{-# LANGUAGE TypeSynonymInstances, FlexibleInstances, FlexibleContexts #-}
+ --------------------------------------------------------------------------------
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
index 56a388d21716..491be5e431ec 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.13.2.3.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.2.3-ghc-7.10.patch
+}
+
src_configure() {
# ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9155
[[ $(ghc-version) == 7.8.2 ]] && replace-hcflags -O[2-9] -O1
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
index 0ce4f06b3445..0b28b638bbdb 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.90.1.0.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.2.3-ghc-7.10.patch
+}
+
src_configure() {
# ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9155
[[ $(ghc-version) == 7.8.2 ]] && replace-hcflags -O[2-9] -O1