summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/timeout/Manifest1
-rw-r--r--dev-ruby/timeout/timeout-0.3.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/timeout/Manifest b/dev-ruby/timeout/Manifest
index 39bb98e32ca2..1422caad7267 100644
--- a/dev-ruby/timeout/Manifest
+++ b/dev-ruby/timeout/Manifest
@@ -1,2 +1,3 @@
DIST timeout-0.2.0.tar.gz 15672 BLAKE2B 2a42efb4475047c947ec1a30637e4ddb8d745651d9d277af9149f952ee88cda335818156d777db283660ac16f338ac53776f6267f040b115078fed9572b4ddc7 SHA512 fe665127e90782602dc4e0f61b8ea39b3c2092a50a0d5f708fcb14bec08443868dd8539417c29166dd925389ef2beed49a67f16bb195cf998104b7121f4c1c4d
DIST timeout-0.3.0.tar.gz 16332 BLAKE2B 9f76ec3ae80c727c745cb4ebfeed67d0d9072fe5b58b4424b5c8670b75c030990219a3243bb80b3082c58ad640f16655881cf6b577a9ab1eecc51e72ff662b26 SHA512 d9f3c25a82be1572ce4286b1066db6a57ea4ee61062ae433c75752ad9e473b952968cfbfe1c9804c8f666a6409dfc9d2b68e8f6960c32a0e48a56d29aaf1bf26
+DIST timeout-0.3.1.tar.gz 16781 BLAKE2B dece63fff06da13516e1ebae591b5cca63e1cefd2ac10c9e254a1d37125fe05f962bb65befeea58de0c9c88f4c475ce62decf349b5268d67bf41a7a31503a54a SHA512 2bcf81df02eedd3eceb370abb1eec94cc77cd93f8c7d034fdd7a9b78c56490f9f49ea64a805e2d9ea5290bc9d8d0a5178ee5c77f6b3d9ea147a4be499c8b918a
diff --git a/dev-ruby/timeout/timeout-0.3.1.ebuild b/dev-ruby/timeout/timeout-0.3.1.ebuild
new file mode 100644
index 000000000000..8b2a780e6031
--- /dev/null
+++ b/dev-ruby/timeout/timeout-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="timeout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a framework for message digest libraries"
+HOMEPAGE="https://github.com/ruby/timeout"
+SRC_URI="https://github.com/ruby/timeout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}