summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/zpaq/zpaq-7.15-r1.ebuild (renamed from app-arch/zpaq/zpaq-7.15.ebuild)14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-arch/zpaq/zpaq-7.15.ebuild b/app-arch/zpaq/zpaq-7.15-r1.ebuild
index aabf4cdca479..cd79e48be432 100644
--- a/app-arch/zpaq/zpaq-7.15.ebuild
+++ b/app-arch/zpaq/zpaq-7.15-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit flag-o-matic pax-utils toolchain-funcs
-MY_P=${PN}${PV/./}
+MY_P="${PN}${PV/./}"
+
DESCRIPTION="Journaling incremental deduplicating archiving compressor"
HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+S="${WORKDIR}"
LICENSE="Unlicense"
SLOT="0"
@@ -16,12 +18,10 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="debug +jit"
# perl for pod2man
-DEPEND="
+BDEPEND="
app-arch/unzip
dev-lang/perl"
-S=${WORKDIR}
-
src_compile() {
use debug || append-cppflags -DNDEBUG
use jit || append-cppflags -DNOJIT
@@ -34,8 +34,8 @@ src_test() {
}
src_install() {
- emake install PREFIX="${ED%/}"/usr
- use jit && pax-mark m "${ED%/}"/usr/bin/zpaq
+ emake install PREFIX="${ED}"/usr
+ use jit && pax-mark m "${ED}"/usr/bin/zpaq
einstalldocs
}