summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/xchm/xchm-1.31.ebuild16
-rw-r--r--app-text/xchm/xchm-9999.ebuild15
2 files changed, 13 insertions, 18 deletions
diff --git a/app-text/xchm/xchm-1.31.ebuild b/app-text/xchm/xchm-1.31.ebuild
index 07a7c38f9ed6..ff9a087ed76a 100644
--- a/app-text/xchm/xchm-1.31.ebuild
+++ b/app-text/xchm/xchm-1.31.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
WX_GTK_VER="3.0-gtk3"
+
inherit desktop wxwidgets xdg-utils
DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
@@ -14,15 +16,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls"
-RDEPEND="
- >=dev-libs/chmlib-0.36
+RDEPEND=">=dev-libs/chmlib-0.36
x11-libs/wxGTK:${WX_GTK_VER}[X]
- nls? ( virtual/libintl )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_configure() {
econf $(use_enable nls)
diff --git a/app-text/xchm/xchm-9999.ebuild b/app-text/xchm/xchm-9999.ebuild
index 13396034ab8a..f7a9523eb4a3 100644
--- a/app-text/xchm/xchm-9999.ebuild
+++ b/app-text/xchm/xchm-9999.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
WX_GTK_VER="3.0-gtk3"
+
inherit autotools desktop git-r3 wxwidgets xdg-utils
DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
@@ -11,18 +13,13 @@ EGIT_REPO_URI="https://github.com/rzvncj/xCHM/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="nls"
-RDEPEND="
- >=dev-libs/chmlib-0.36
+RDEPEND=">=dev-libs/chmlib-0.36
x11-libs/wxGTK:${WX_GTK_VER}[X]
- nls? ( virtual/libintl )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_prepare() {
default