summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/polymake/Manifest1
-rw-r--r--sci-mathematics/polymake/polymake-2.14-r1.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-mathematics/polymake/Manifest b/sci-mathematics/polymake/Manifest
index 0ff9bf57b0d0..fff85a5231f9 100644
--- a/sci-mathematics/polymake/Manifest
+++ b/sci-mathematics/polymake/Manifest
@@ -1,2 +1 @@
-DIST polymake-2.14-minimal.tar.bz2 1996581 SHA256 c43b525c6f329ae2d8eb6d0e2af63f7846c4e5d408627665a28d0f421bbbcf9b SHA512 8989a8d2eb42c03e46569eca24334083154ff5107d7cd7d9dc481790b1553acd38025bd48ca016407e5c08b4b08f8062e19a1d4828ef535f83292510bdf5cd07 WHIRLPOOL 3f1521c60eafcff60b8ab2a443ff051835ee1c667eefcd59b33227e7a84293ccaefad4bc05eea4b8c541dea513b85b4e8538b6b572d762f2e1167b733029ec54
DIST polymake-3.0r2.tar.bz2 37695790 SHA256 e7c0f8e3a45ea288d2fb4ae781a1dcea913ef9c275fed401632cdb11a672d6dc SHA512 b4c22b2c6da8ef597dc05a44a30c7a55fd924a96854cde3f725095465972eabe1e24508f8e5d544f3131c82c973117b15983c38a0242fc7f1d4a4a8ecddb1d46 WHIRLPOOL 5a236ac32de0dd19e7f0f5b8b1b42f2b72fa2392ee098718383a8dfd0f1d1db3946d5f4f75bd9e4c075033deebcd87ddbb28ce70733d6371fa4624b8b6a4edd1
diff --git a/sci-mathematics/polymake/polymake-2.14-r1.ebuild b/sci-mathematics/polymake/polymake-2.14-r1.ebuild
deleted file mode 100644
index a1e861349b18..000000000000
--- a/sci-mathematics/polymake/polymake-2.14-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="research tool for polyhedral geometry and combinatorics"
-SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${P}-minimal.tar.bz2"
-HOMEPAGE="http://polymake.org"
-
-IUSE="+cdd lrs ppl bliss group +libnormaliz singular libpolymake"
-
-REQUIRED_USE="group? ( cdd lrs )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# do not allow new perl versions because our testbuilds segfault
-DEPEND="<dev-lang/perl-5.21
- dev-libs/gmp:0=
- dev-libs/mpfr:0
- dev-libs/libxml2:2
- dev-libs/libxslt
- ppl? ( dev-libs/ppl )
- cdd? ( sci-libs/cddlib )
- lrs? ( >=sci-libs/lrslib-051[gmp] )
- bliss? ( sci-libs/bliss[gmp] )
- group? ( dev-libs/boost:= )
- libnormaliz? ( dev-libs/boost:= )
- singular? ( >=sci-mathematics/singular-4.0.1 )"
-RDEPEND="${DEPEND}
- dev-perl/XML-LibXML
- dev-perl/XML-LibXSLT
- dev-perl/XML-Writer
- dev-perl/Term-ReadLine-Gnu"
-
-src_prepare() {
- einfo "During compile this package uses up to"
- einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
- einfo "you run into trouble."
-}
-
-src_configure () {
- export CXXOPT=$(get-flag -O)
-
- # We need to define BLISS_USE_GMP if bliss was built with gmp support.
- # Therefore we require gmp support on bliss, so that the package
- # manager can prevent rebuilds with changed gmp flag.
- if use bliss ; then
- append-cxxflags -DBLISS_USE_GMP
- fi
-
- # Configure does not accept --host, therefore econf cannot be used
-
- # Some of the options do not support using just '--with-option'
- local myconf=""
- use !group && myconf="$myconf --without-group"
- use !libnormaliz && myconf="$myconf --without-libnormaliz"
- use !libpolymake && myconf="$myconf --without-callable"
-
- # And many other --with-arguments expect a path: --with-option=/path
- ./configure --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
- --without-prereq \
- --without-java \
- $(use_with cdd cdd "${EPREFIX}/usr") \
- $(use_with lrs lrs "${EPREFIX}/usr") \
- $(use_with ppl ppl "${EPREFIX}/usr") \
- $(use_with bliss bliss "${EPREFIX}/usr") \
- $(use_with singular singular "${EPREFIX}/usr") \
- ${myconf} || die
-}
-
-src_install(){
- emake -j1 DESTDIR="${D}" install
-}
-
-pkg_postinst(){
- elog "Docs can be found on http://www.polymake.org/doku.php/documentation"
- elog " "
- elog "Support for jreality is missing, sorry (see bug #346073)."
- elog " "
- elog "Additional features for polymake are available through external"
- elog "software such as sci-mathmatics/4ti2 and sci-mathematics/topcom."
- elog "After installing new external software run 'polymake --reconfigure'."
-}