summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch15
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.1-r2.ebuild45
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch b/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch
new file mode 100644
index 000000000000..64a599e00cdb
--- /dev/null
+++ b/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch
@@ -0,0 +1,15 @@
+diff -Naruw a/pkg/pgadmin3.desktop b/pkg/pgadmin3.desktop
+--- a/pkg/pgadmin3.desktop 2013-02-22 12:21:19.000000000 -0500
++++ b/pkg/pgadmin3.desktop 2015-02-04 15:36:34.845312953 -0500
+@@ -2,9 +2,8 @@
+ Encoding=UTF-8
+ Name=pgAdmin III
+ Exec=/usr/bin/pgadmin3
+-Icon=/usr/share/pgadmin3/pgAdmin3.png
++Icon=/usr/share/pixmaps/pgadmin3.png
+ Type=Application
+-Categories=Application;Development;
+-MimeType=text/html
++Categories=Development;
+ DocPath=/usr/share/pgadmin3/docs/en_US/index.html
+ Comment=PostgreSQL Tools
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.1-r2.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.1-r2.ebuild
new file mode 100644
index 000000000000..27d932986e32
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.22.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +databasedesigner"
+
+DEPEND="
+ >=dev-db/postgresql-8.4.0:=
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1
+ x11-libs/wxGTK:3.0=[X]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-desktop-r1.patch" )
+
+src_configure() {
+ WX_GTK_VER="3.0"
+
+ setup-wxwidgets
+
+ econf --with-wx-version=${WX_GTK_VER} \
+ $(use_enable debug) \
+ $(use_enable databasedesigner)
+}
+
+src_install() {
+ default
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}