summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/unshield/unshield-1.4.3.ebuild2
-rw-r--r--app-misc/pdfpc/pdfpc-4.3.2.ebuild6
-rw-r--r--app-text/apvlv/apvlv-0.1.5-r2.ebuild6
-rw-r--r--dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild8
-rw-r--r--dev-libs/poco/poco-1.9.0-r2.ebuild10
-rw-r--r--dev-util/apitrace/apitrace-8.0.ebuild5
-rw-r--r--media-gfx/maim/maim-5.5.3.ebuild4
-rw-r--r--media-gfx/maim/maim-9999.ebuild4
-rw-r--r--media-sound/flacon/flacon-5.5.1.ebuild4
-rw-r--r--media-sound/supercollider/supercollider-3.10.2.ebuild6
-rw-r--r--net-analyzer/arpon/arpon-2.7.2-r1.ebuild4
-rw-r--r--net-irc/anope/anope-2.0.6.ebuild8
-rw-r--r--net-libs/rabbitmq-c/rabbitmq-c-0.10.0.ebuild4
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild8
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild2
-rw-r--r--x11-misc/slop/slop-9999.ebuild4
-rw-r--r--x11-misc/xcalib/xcalib-0.10.ebuild2
-rw-r--r--x11-wm/ctwm/ctwm-4.0.3.ebuild6
19 files changed, 51 insertions, 50 deletions
diff --git a/app-arch/unshield/unshield-1.4.3.ebuild b/app-arch/unshield/unshield-1.4.3.ebuild
index f81ff080ff9d..80da8114a2ae 100644
--- a/app-arch/unshield/unshield-1.4.3.ebuild
+++ b/app-arch/unshield/unshield-1.4.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="InstallShield CAB file extractor"
HOMEPAGE="https://github.com/twogood/unshield"
diff --git a/app-misc/pdfpc/pdfpc-4.3.2.ebuild b/app-misc/pdfpc/pdfpc-4.3.2.ebuild
index 8de1c1444c14..889c7715a7fb 100644
--- a/app-misc/pdfpc/pdfpc-4.3.2.ebuild
+++ b/app-misc/pdfpc/pdfpc-4.3.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
VALA_MIN_API_VERSION="0.34"
VALA_MAX_API_VERSION="0.42" # fix sed line if you increase this
-inherit vala cmake-utils
+inherit vala cmake
DESCRIPTION="Presenter console with multi-monitor support for PDF files"
HOMEPAGE="https://pdfpc.github.io"
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}"
BDEPEND="$(vala_depend)"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e "s/valac/valac valac-0.42 valac-0.40 valac-0.36 valac-0.34/" cmake/vala/FindVala.cmake || die
vala_src_prepare
@@ -40,5 +40,5 @@ src_configure(){
-DSYSCONFDIR="${EPREFIX}/etc"
-DMOVIES=$(usex gstreamer on off)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/app-text/apvlv/apvlv-0.1.5-r2.ebuild b/app-text/apvlv/apvlv-0.1.5-r2.ebuild
index e952e34db067..5138d37d5edc 100644
--- a/app-text/apvlv/apvlv-0.1.5-r2.ebuild
+++ b/app-text/apvlv/apvlv-0.1.5-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit xdg cmake-utils desktop
+inherit xdg cmake desktop
DESCRIPTION="Alf's PDF Viewer Like Vim"
HOMEPAGE="https://naihe2010.github.com/apvlv/"
@@ -44,10 +44,10 @@ src_configure() {
-DAPVLV_WITH_DJVU=$(usex djvu)
-DAPVLV_ENABLE_DEBUG=$(usex debug)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newicon -s 32 icons/pdf.png ${PN}.png
}
diff --git a/dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild b/dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild
index 7816ece23a2e..c8a700b3a51c 100644
--- a/dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild
+++ b/dev-db/sqlitebrowser/sqlitebrowser-3.11.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="SQLite Database Browser"
HOMEPAGE="https://sqlitebrowser.org"
@@ -41,7 +41,7 @@ RDEPEND="${DEPEND}
PATCHES=( "${FILESDIR}"/${PN}-3.11.1-unbundle.patch )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
rm -r libs || die
sed -i 's#"src/qhexedit.h"#<qhexedit.h>#' src/EditDialog.cpp || die
#find libs/{antlr-2.7.7,qcustomplot-source,qscintilla} -delete || die
@@ -58,10 +58,10 @@ src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon images/sqlitebrowser.svg
}
diff --git a/dev-libs/poco/poco-1.9.0-r2.ebuild b/dev-libs/poco/poco-1.9.0-r2.ebuild
index c122dc9b1642..a0c09ae84691 100644
--- a/dev-libs/poco/poco-1.9.0-r2.ebuild
+++ b/dev-libs/poco/poco-1.9.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++ libraries for building network-based applications"
HOMEPAGE="https://pocoproject.org/"
@@ -52,7 +52,7 @@ S="${WORKDIR}/${PN}-${P}-release"
PATCHES=( "${FILESDIR}/${PN}-1.7.2-iodbc-incdir.patch" )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use test ; then
# ignore missing tests on experimental library
@@ -115,15 +115,15 @@ src_configure() {
-DENABLE_ZIP="$(usex zip)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
- POCO_BASE="${S}" cmake-utils_src_test
+ POCO_BASE="${S}" cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples ; then
for sd in */samples ; do
diff --git a/dev-util/apitrace/apitrace-8.0.ebuild b/dev-util/apitrace/apitrace-8.0.ebuild
index d37d8c20af6b..27ebcc72ba8a 100644
--- a/dev-util/apitrace/apitrace-8.0.ebuild
+++ b/dev-util/apitrace/apitrace-8.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python2_7 )
inherit cmake-multilib python-single-r1
@@ -49,7 +50,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# The apitrace code grubs around in the internal zlib structures.
# We have to extract this header and clean it up to keep that working.
@@ -79,7 +80,7 @@ src_configure() {
-DENABLE_GUI=OFF
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_parallel_foreach_abi my_configure
diff --git a/media-gfx/maim/maim-5.5.3.ebuild b/media-gfx/maim/maim-5.5.3.ebuild
index d046bb0b70e6..f0567fc401b0 100644
--- a/media-gfx/maim/maim-5.5.3.ebuild
+++ b/media-gfx/maim/maim-5.5.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Commandline tool to take screenshots of the desktop"
HOMEPAGE="https://github.com/naelstrof/maim"
@@ -37,5 +37,5 @@ src_configure() {
local mycmakeargs=(
-DMAIM_UNICODE=$(usex unicode)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-gfx/maim/maim-9999.ebuild b/media-gfx/maim/maim-9999.ebuild
index d046bb0b70e6..f0567fc401b0 100644
--- a/media-gfx/maim/maim-9999.ebuild
+++ b/media-gfx/maim/maim-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Commandline tool to take screenshots of the desktop"
HOMEPAGE="https://github.com/naelstrof/maim"
@@ -37,5 +37,5 @@ src_configure() {
local mycmakeargs=(
-DMAIM_UNICODE=$(usex unicode)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-sound/flacon/flacon-5.5.1.ebuild b/media-sound/flacon/flacon-5.5.1.ebuild
index e6310352d358..ccdd9a6a41dd 100644
--- a/media-sound/flacon/flacon-5.5.1.ebuild
+++ b/media-sound/flacon/flacon-5.5.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# Tests require lots of disk space
CHECKREQS_DISK_BUILD=10G
-inherit check-reqs cmake-utils eutils virtualx xdg-utils
+inherit check-reqs cmake eutils virtualx xdg-utils
DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
HOMEPAGE="https://flacon.github.io/"
@@ -58,7 +58,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTS="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/supercollider/supercollider-3.10.2.ebuild b/media-sound/supercollider/supercollider-3.10.2.ebuild
index 23afd5ef19dd..0d26b89cbf3e 100644
--- a/media-sound/supercollider/supercollider-3.10.2.ebuild
+++ b/media-sound/supercollider/supercollider-3.10.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils readme.gentoo-r1 xdg-utils
+inherit cmake readme.gentoo-r1 xdg-utils
DESCRIPTION="An environment and a programming language for real time audio synthesis."
HOMEPAGE="https://supercollider.github.io/"
@@ -99,11 +99,11 @@ src_configure() {
-DGC_SANITYCHECK=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use emacs && newdoc editors/scel/README.md README.emacs
use gedit && newdoc editors/sced/README.md README.gedit
diff --git a/net-analyzer/arpon/arpon-2.7.2-r1.ebuild b/net-analyzer/arpon/arpon-2.7.2-r1.ebuild
index 92f553b7ab10..2ccf4afb09f1 100644
--- a/net-analyzer/arpon/arpon-2.7.2-r1.ebuild
+++ b/net-analyzer/arpon/arpon-2.7.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
@@ -31,7 +31,7 @@ DOCS=( AUTHOR CHANGELOG )
S="${WORKDIR}"/${MY_P}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}
diff --git a/net-irc/anope/anope-2.0.6.ebuild b/net-irc/anope/anope-2.0.6.ebuild
index 1cf036e12d83..2953f690d0dc 100644
--- a/net-irc/anope/anope-2.0.6.ebuild
+++ b/net-irc/anope/anope-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user
+inherit cmake user
DESCRIPTION="Anope IRC Services"
HOMEPAGE="https://anope.org"
@@ -98,7 +98,7 @@ src_prepare() {
# Avoid a silly sandbox error - tries to delete /usr/lib/modules
sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -111,11 +111,11 @@ src_configure() {
-DCONF_DIR="/etc/anope"
-DLOGS_DIR="../var/log/anope/"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/anope-init.d" "${PN}"
cp "${FILESDIR}/anope-conf.d-v2" "${T}" || die
sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \
diff --git a/net-libs/rabbitmq-c/rabbitmq-c-0.10.0.ebuild b/net-libs/rabbitmq-c/rabbitmq-c-0.10.0.ebuild
index d8c82ef94e1a..7ca183a40a57 100644
--- a/net-libs/rabbitmq-c/rabbitmq-c-0.10.0.ebuild
+++ b/net-libs/rabbitmq-c/rabbitmq-c-0.10.0.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit cmake-utils
+inherit cmake
DESCRIPTION="RabbitMQ C client"
HOMEPAGE="https://github.com/alanxz/rabbitmq-c"
@@ -44,7 +44,7 @@ src_configure() {
-DBUILD_TOOLS_DOCS=$(usex tools)
-DENABLE_SSL_SUPPORT=$(usex ssl)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index 64c2d82ce771..92be9c4426d8 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -13,7 +13,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -64,16 +64,16 @@ src_configure() {
mycmakeargs+=( -DHPX_WITH_MALLOC=system )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# avoid over-suscribing
- cmake-utils_src_make -j1 tests
+ cmake_build -j1 tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 64c2d82ce771..92be9c4426d8 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -13,7 +13,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -64,16 +64,16 @@ src_configure() {
mycmakeargs+=( -DHPX_WITH_MALLOC=system )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# avoid over-suscribing
- cmake-utils_src_make -j1 tests
+ cmake_build -j1 tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
index 4285248dec78..f0895523101e 100644
--- a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A pomodoro app that blocks distractions while you work"
HOMEPAGE="https://github.com/iamsergio/flow-pomodoro"
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
index efec20aaad05..59a8423ff8f0 100644
--- a/x11-misc/slop/slop-9999.ebuild
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Application that queries the user for a selection for printing"
HOMEPAGE="https://github.com/naelstrof/slop"
@@ -37,5 +37,5 @@ src_configure() {
local mycmakeargs=(
-DSLOP_OPENGL=$(usex opengl)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/x11-misc/xcalib/xcalib-0.10.ebuild b/x11-misc/xcalib/xcalib-0.10.ebuild
index b97a56578667..e312c0156bf0 100644
--- a/x11-misc/xcalib/xcalib-0.10.ebuild
+++ b/x11-misc/xcalib/xcalib-0.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Tiny monitor calibration loader for X.org"
HOMEPAGE="https://github.com/OpenICC/xcalib"
diff --git a/x11-wm/ctwm/ctwm-4.0.3.ebuild b/x11-wm/ctwm/ctwm-4.0.3.ebuild
index cceee0bca32a..fbaccc9e453d 100644
--- a/x11-wm/ctwm/ctwm-4.0.3.ebuild
+++ b/x11-wm/ctwm/ctwm-4.0.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A clean, light window manager"
HOMEPAGE="https://ctwm.org/"
@@ -30,7 +30,7 @@ DEPEND="
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# implicit 'isspace'
sed -i parse.c -e "/<stdio.h>/ a#include <ctype.h>" || die
@@ -42,5 +42,5 @@ src_configure() {
-DDOCDIR=/usr/share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}