summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/munt-mt32emu/Manifest1
-rw-r--r--media-libs/munt-mt32emu/files/munt-mt32emu-2.6.1-docs.patch14
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/Manifest b/media-libs/munt-mt32emu/Manifest
index 6a00dd1d8f58..787acea436e1 100644
--- a/media-libs/munt-mt32emu/Manifest
+++ b/media-libs/munt-mt32emu/Manifest
@@ -1 +1,2 @@
DIST libmt32emu_2_5_3.tar.gz 527698 BLAKE2B 1ca31f2da92d77f9c3d34bb8c9f19e34e83cc82751ba08dfda1240a28b49e36c2acf3a6d8aab6e62107df4d88645e77d447e332968007fe865882d54e71475de SHA512 c801e22e861898281316109533ca6264f5a9cf778d4f0bb14b49bb6d04d53b7e60cd8320d5b29a63534f6c470b4feb67c881e86c49b7860a98639ce01b99debf
+DIST libmt32emu_2_6_1.tar.gz 572860 BLAKE2B 3ba8ec7d9b73a83341eafc990e2c5a2c5c439564ad43ac3d6f9ab3325225c863418fd901e5424e57343b40cb8cc873345003fd299d6a22d02ff3872681ff164e SHA512 888c417cce04b31b45858220a6615105611471567be8cce91c2053885c4b677a09667310bfab702bbf62f4b7230bb7c2357cb480087f6e4daecbd58e464e4212
diff --git a/media-libs/munt-mt32emu/files/munt-mt32emu-2.6.1-docs.patch b/media-libs/munt-mt32emu/files/munt-mt32emu-2.6.1-docs.patch
new file mode 100644
index 000000000000..67c744ad20a5
--- /dev/null
+++ b/media-libs/munt-mt32emu/files/munt-mt32emu-2.6.1-docs.patch
@@ -0,0 +1,14 @@
+diff -Naur a/32emu/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2022-03-06 14:47:08.000000000 +0000
++++ b/CMakeLists.txt 2022-03-15 23:26:06.230301579 +0000
+@@ -377,8 +377,8 @@
+ endif()
+
+ install(FILES
+- AUTHORS.txt COPYING.txt COPYING.LESSER.txt NEWS.txt README.md TODO.txt
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/doc/munt/${PROJECT_NAME}
++ AUTHORS.txt NEWS.txt README.md TODO.txt
++ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/doc/$ENV{PF}
+ )
+
+ # Facilitates usage of the library in another project either through
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
new file mode 100644
index 000000000000..4a07225533b4
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}