summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/sofia-sip/Manifest1
-rw-r--r--net-libs/sofia-sip/sofia-sip-1.13.9.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/sofia-sip/Manifest b/net-libs/sofia-sip/Manifest
index 0f045034c438..f445d44655ed 100644
--- a/net-libs/sofia-sip/Manifest
+++ b/net-libs/sofia-sip/Manifest
@@ -1 +1,2 @@
DIST sofia-sip-1.13.8.tar.gz 2551359 BLAKE2B 505d3cdac29b00589f63782c296b68f36ba9247ef87bcbda7b2765c0079aa2313ac72c0062ada5ba29e07faa892a991722c53468756ce8ef4cd385b90afda564 SHA512 f857eb9cf25d3306476bc6d0bda786385529021d498cf0c2c779cdbae31295af4ed59a67fb0c882b09bac738623d273a94ebbda360c7a2b3d7da140852ccc6fa
+DIST sofia-sip-1.13.9.tar.gz 2551559 BLAKE2B 69b5c0e995475a23012e2608a4b146058689c5243221ea1569e40514408884cf602dce2a53cf2468c449bbce14f03082aece0a9249f1a517829d963e56a1792d SHA512 bec7c11d94cc7243d6e1d11eb6fe0b666c018d9eb599896766b55773825cf3e218267d7e6efd1a9f7cb6e1eab79c2b6a38095bfc5a8f013a647588a676f707ec
diff --git a/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild b/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
new file mode 100644
index 000000000000..d974b5a9f4df
--- /dev/null
+++ b/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="RFC3261 compliant SIP User-Agent library"
+HOMEPAGE="https://github.com/freeswitch/sofia-sip"
+SRC_URI="https://github.com/freeswitch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD public-domain" # See COPYRIGHT
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc RELEASE
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}