summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/valijson/Manifest1
-rw-r--r--dev-cpp/valijson/valijson-0.7.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index 3094c2282938..b112a7c010c0 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1,2 +1 @@
-DIST valijson-0.7.tar.gz 2060214 BLAKE2B d2e1c58e37213e44d7d6af173691cad3853e87648948c229ea683bfcba8b19256b0230852b0537c2dbdd7084fcf1ac068e320c5f59a69e446610390b82e76474 SHA512 662e53bf1cac4def19792392cda7cbfe2cbadf77b768eb69b2dec693b16f85f32fa2e9b97eae36569cfcc9ac45f1e6338967423cf415d6bcd90372bc49793a2d
DIST valijson-1.0.tar.gz 721078 BLAKE2B 74f4a061266a6ee8fba9d93b4e1df20dc828d85169f865bdb60ba9f5217ee422324a09788b02b4ddd18a92d906c64863a5bd7c1250f8bdb62fd9f00f3d73c7e7 SHA512 a206954b11e92cbebbebf094e6f0925a270ebd6bec49cbdb7adda5a4cec93587a5a61ebbce105846c3950cf5df74bfdd5f5bb1ffbf73315f45c7a6cda2b77db9
diff --git a/dev-cpp/valijson/valijson-0.7.ebuild b/dev-cpp/valijson/valijson-0.7.ebuild
deleted file mode 100644
index ca723120f1e0..000000000000
--- a/dev-cpp/valijson/valijson-0.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Header-only C++ library for JSON Schema validation"
-HOMEPAGE="https://github.com/tristanpenman/valijson"
-SRC_URI="https://github.com/tristanpenman/valijson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -Dvalijson_BUILD_TESTS=$(usex test)
- )
-
- if use test; then
- # Fix relative paths to test data
- sed -i -e "s:../tests/data/documents/:../${P}/tests/data/documents/:" tests/test_adapter_comparison.cpp || die
- sed -i -e "s:../tests/data:../${P}/tests/data:" tests/test_validation_errors.cpp || die
- sed -i -e "s:../thirdparty/:../${P}/thirdparty/:" -e "s:../doc/schema/:../${P}/doc/schema/:" tests/test_validator.cpp || die
- fi
-
- # -Werror is too aggressive due to false positives with gcc-12, see bug #866153
- sed -i -e 's/-Werror//g' ../${P}/CMakeLists.txt || die
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ./test_suite || die
-}
-
-src_install() {
- # there is no target for installing headers, so do it manually
- doheader -r include/*
-}