summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/sundials/Manifest1
-rw-r--r--sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch15
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild79
3 files changed, 0 insertions, 95 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index dc11161c3fdd..e9bc6740cff3 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -1,3 +1,2 @@
-DIST sundials-5.2.0.tar.gz 18639221 BLAKE2B c10e6deb5839993b8601347be94412d0b0c058084b4dc0d380681f7b4debd535f9736c2ef734e9fd84c6ddc190ab05f46abcb711225ec1f156a18d8edb6317fb SHA512 99163a104e436dab4779c77519502b5614b65d726324b29b14236315f6916beb5863fcd56b5acf19f62985c033b227fba1ebd3d3c4607ce991d94ee7739bb55f
DIST sundials-5.8.0.tar.gz 24012815 BLAKE2B f707ad7465218532f3dc4df7627b87933b2bc52be6f1ad290b91ab83a3414ae83bc64503126af8772daa000f58a89855d7ca35fe74fa21bd91180695582442c7 SHA512 d22e699aaddaeef026e91e18dd070d06278c75b6980b36c6fb2e50203ba6445420e4a8e0612a6317dcaa521aeffbdf62ab88737be235ef70cef3a8be02a13dbb
DIST sundials-6.2.0.tar.gz 82410068 BLAKE2B c6aa9735198465bb458590ef1a90101e246202632afd6bd7f48970b9a2752810ce8c5be7983097cd816189cb994efbddf8d34706665846c67d6442bd7c12db38 SHA512 0dd0a2bf6390a13a5846caf440aa6d459f3890f6d13c0eff8c8180a92a636d6eae7f64679d45acd2048de742d4c644e2ae112cb09028b3fdef10a247bee44c0b
diff --git a/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch b/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch
deleted file mode 100644
index 8fb6c977ca76..000000000000
--- a/sci-libs/sundials/files/sundials-5.2.0-fix-license-install-path.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Naur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-04-01 00:03:37.000000000 +0300
-+++ b/CMakeLists.txt 2020-04-21 13:27:58.000000000 +0300
-@@ -1146,9 +1146,9 @@
- # install license and notice files
- install(
- FILES ${PROJECT_SOURCE_DIR}/LICENSE
-- DESTINATION include/sundials
-+ DESTINATION share/doc/sundials-5.2.0
- )
- install(
- FILES ${PROJECT_SOURCE_DIR}/NOTICE
-- DESTINATION include/sundials
-+ DESTINATION share/doc/sundials-5.2.0
- )
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
deleted file mode 100644
index 5af24cd4ed75..000000000000
--- a/sci-libs/sundials/sundials-5.2.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-# if FFLAGS and FCFLAGS are set then should be equal
-
-inherit cmake fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Suite of nonlinear solvers"
-HOMEPAGE="https://computation.llnl.gov/projects/sundials"
-SRC_URI="https://computation.llnl.gov/projects/sundials/download/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/$(ver_cut 1)"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
-REQUIRED_USE="hypre? ( mpi )"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- lapack? ( virtual/lapack )
- mpi? ( virtual/mpi sci-libs/hypre:= )
- sparse? ( sci-libs/klu )
- superlumt? ( sci-libs/superlu_mt:= )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- use fortran && fortran-2_pkg_setup
-}
-
-src_prepare() {
- # bug #707240
- append-cflags -fcommon
-
- cmake_src_prepare
-}
-
-src_configure() {
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS="$(usex static-libs)"
- -DCXX_ENABLE="$(usex cxx)"
- -DFCMIX_ENABLE="$(usex fortran)"
- -DF90_ENABLE="$(usex fortran)"
- -DHYPRE_ENABLE="$(usex hypre)"
- -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
- -DKLU_ENABLE="$(usex sparse)"
- -DLAPACK_ENABLE="$(usex lapack)"
- -DMPI_ENABLE="$(usex mpi)"
- -DOPENMP_ENABLE="$(usex openmp)"
- -DPTHREAD_ENABLE="$(usex threads)"
- -DSUPERLUMT_ENABLE="$(usex superlumt)"
- -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
- -DSUPERLUMT_LIBRARY="-lsuperlu_mt"
- -DEXAMPLES_ENABLE="$(usex examples)"
- -DEXAMPLES_INSTALL=ON
- -DEXAMPLES_INSTALL_PATH="${EPREFIX}/usr/share/doc/${PF}/examples"
- -DUSE_GENERIC_MATH=ON
- )
- use sparse && mycmakeargs+=( -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so" )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- use doc && dodoc doc/*/*.pdf
-}