summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/selenium-webdriver/files/selenium-webdriver-4.11.0-selenium-manager.patch22
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-4.11.0-r1.ebuild47
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/files/selenium-webdriver-4.11.0-selenium-manager.patch b/dev-ruby/selenium-webdriver/files/selenium-webdriver-4.11.0-selenium-manager.patch
new file mode 100644
index 000000000000..e99fd35549e0
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/files/selenium-webdriver-4.11.0-selenium-manager.patch
@@ -0,0 +1,22 @@
+--- a/lib/selenium/webdriver/common/selenium_manager.rb 2023-08-25 13:17:11.962989216 +0200
++++ b/lib/selenium/webdriver/common/selenium_manager.rb 2023-08-25 13:18:02.983400166 +0200
+@@ -31,7 +31,7 @@
+ attr_writer :bin_path
+
+ def bin_path
+- @bin_path ||= '../../../../../bin'
++ @bin_path ||= '/usr/bin'
+ end
+
+ # @param [Options] options browser options.
+--- a/lib/selenium/webdriver/common/selenium_manager.rb 2023-08-25 13:27:16.215857048 +0200
++++ b/lib/selenium/webdriver/common/selenium_manager.rb 2023-08-25 13:27:42.664070234 +0200
+@@ -81,7 +81,7 @@
+ elsif Platform.mac?
+ '/macos/selenium-manager'
+ elsif Platform.linux?
+- '/linux/selenium-manager'
++ '/selenium-manager'
+ end
+ location = File.expand_path(path, __FILE__)
+
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-4.11.0-r1.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-4.11.0-r1.ebuild
new file mode 100644
index 000000000000..9428e4c5bea5
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-4.11.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_GEMSPEC="selenium-webdriver.gemspec"
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" >=dev-util/selenium-manager-${PV}"
+
+ruby_add_rdepend "
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubyzip-1.2.2:*
+ dev-ruby/websocket:0
+"
+
+PATCHES=( "${FILESDIR}/${P}-selenium-manager.patch" )
+
+all_ruby_prepare() {
+ # Remove the pre-compiled selenium-manager executables
+ rm -fr bin || die
+}