summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nbdime/Manifest4
-rw-r--r--dev-python/nbdime/nbdime-3.1.1-r2.ebuild101
-rw-r--r--dev-python/nbdime/nbdime-3.2.0.ebuild78
3 files changed, 0 insertions, 183 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index 0ce9c4b663d3..778acd0325ed 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1,5 +1 @@
-DIST nbdime-3.1.1-jupyter_server2.patch 9483 BLAKE2B 767f7c848a5d840c1ac26d42f4074888163fd0bf63b774e9f79c5b7738f7f43453e35c93bdbad9cb10bb52315d67e1de6207b3463bbb885a6d095ada2bfae7ef SHA512 306764a2dd8770ee5041f5ebe076c3de5da9444166de3b77c7a6c37ef1a13c57f1adecf11e99a6f812930b133ae4ec7229de61f8a789804de77abd518f2e08b4
-DIST nbdime-3.1.1-py3.11.patch 873 BLAKE2B cc7e7a2cb7a95eb4280d1ee64b4563691c099e0c9d0613283dcbdf6cdebabc78f5c8f181006fb7176df43950ec86be880620e0381dffcf5614f8c05b78f7c4dd SHA512 e26054c7ed2c8201e3e6b6d4e18c80f3b5a3a9a21d201f2ba1f68cc2dcd0e6c4bc2d82c57cd07400f0ee6ce8a52e9a5c8e77000cd7912d3ca6b2ea53b80909fe
-DIST nbdime-3.1.1.tar.gz 7723671 BLAKE2B 2a8f0e7281e1830d6ab15bcc25c1be69e37b575e4ecde1f61f5d697be8cf556c7e3bfdf11375f47808aa812bebbbaf4bfacaa121c17fefb9cc8a80ba9ca08d1c SHA512 268c2c3f8c45dd4a55a632d55a817ee4a4283c5411b73915bb514a9b546ebcdebd7481e93a1e7ba66c30bcdc70932ba7af83de454d3d0ab9d2cfa24bc19c8d9f
-DIST nbdime-3.2.0.tar.gz 7513703 BLAKE2B adfbb22e4591112b19079fed6fd7ac4db9e9169a5122cb1e9ad282ef9d07af9f3e69b84b32558af539abd5c7c010eb42182c29b4eba486159961b35cb709044e SHA512 875ecd64f55b26bdb239e489022ee33ed28dd3bd459c9f8ef0c40d86011d4b024e42442cc347ab193a1ae6bec0a0a385894a381f317f74676e7e43edd3fdbea1
DIST nbdime-3.2.1.tar.gz 7642926 BLAKE2B 245a2b0ca112574a9622855acc8db43595cd7f29f6fe2c1a1f70254984edb395817f65246613b5f41f513464fd37264f2c520237bf44570814bfa6131fdf22a8 SHA512 6ead97a88d587dab00df22d59adb2b80b7f81f47929a6be94b5e848a5c72f7420fac49e1a6a3b87138db75e6c1f46eef67a57a58d6e9d568b69f4e555bb7ed60
diff --git a/dev-python/nbdime/nbdime-3.1.1-r2.ebuild b/dev-python/nbdime/nbdime-3.1.1-r2.ebuild
deleted file mode 100644
index 10139140e53e..000000000000
--- a/dev-python/nbdime/nbdime-3.1.1-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi edos2unix
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/nbdime/
- https://pypi.org/project/nbdime/
-"
-SRC_URI+="
- https://github.com/jupyter/nbdime/commit/0e1cdaa77f57aa7f609d5ef7da26a52814c7ff74.patch
- -> ${P}-jupyter_server2.patch
- https://github.com/jupyter/nbdime/commit/f67a809262b45ed0eaedc840b0e5d979eaa6965d.patch
- -> ${P}-py3.11.patch
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jupyter-server[${PYTHON_USEDEP}]
- dev-python/jupyter-server-mathjax[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/tabulate[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/recommonmark \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-PATCHES=(
- "${DISTDIR}"/${P}-jupyter_server2.patch
- "${DISTDIR}"/${P}-py3.11.patch
-)
-
-EPYTEST_DESELECT=(
- nbdime/tests/test_decision_tools.py::test_build_diffs_unsorted
- nbdime/tests/test_diff_json_conversion.py::test_diff_to_json_patch
- nbdime/tests/test_merge_notebooks.py::test_merge_conflicts_get_diff_indices_shifted
- nbdime/tests/test_merge_notebooks.py::test_merge_inserts_within_deleted_range
- nbdime/tests/test_merge_notebooks.py::test_merge_interleave_cell_add_remove
- nbdime/tests/test_merge_notebooks.py::test_merge_multiline_cell_source_conflict
- nbdime/tests/test_merge.py::test_deep_merge_lists_delete_no_conflict__currently_expected_failures
- nbdime/tests/test_server_extension.py::test_diff_api_checkpoint
- nbdime/tests/test_web.py::test_api_diff
- nbdime/tests/test_web.py::test_api_merge
- nbdime/tests/test_web.py::test_fetch_diff
- nbdime/tests/test_web.py::test_fetch_merge
- nbdime/tests/test_web.py::test_offline_mathjax
-)
-
-src_prepare() {
- edos2unix \
- setupbase.py \
- nbdime/tests/conftest.py \
- nbdime/tests/test_cli_apps.py \
- nbdime/tests/test_web.py \
- nbdime/webapp/nbdimeserver.py
-
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- DISTUTILS_ARGS=( --skip-npm )
-}
-
-src_test() {
- # user.email and user.name are not configured in the sandbox
- git config --global user.email "larry@gentoo.org" || die
- git config --global user.name "Larry the Cow" || die
-
- distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- mv "${ED}"{/usr,}/etc || die
-}
diff --git a/dev-python/nbdime/nbdime-3.2.0.ebuild b/dev-python/nbdime/nbdime-3.2.0.ebuild
deleted file mode 100644
index bbde7615968c..000000000000
--- a/dev-python/nbdime/nbdime-3.2.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/nbdime/
- https://pypi.org/project/nbdime/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jupyter-server[${PYTHON_USEDEP}]
- dev-python/jupyter-server-mathjax[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/tabulate[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/recommonmark \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- nbdime/tests/test_decision_tools.py::test_build_diffs_unsorted
- nbdime/tests/test_diff_json_conversion.py::test_diff_to_json_patch
- nbdime/tests/test_merge_notebooks.py::test_merge_conflicts_get_diff_indices_shifted
- nbdime/tests/test_merge_notebooks.py::test_merge_inserts_within_deleted_range
- nbdime/tests/test_merge_notebooks.py::test_merge_interleave_cell_add_remove
- nbdime/tests/test_merge_notebooks.py::test_merge_multiline_cell_source_conflict
- nbdime/tests/test_merge.py::test_deep_merge_lists_delete_no_conflict__currently_expected_failures
- nbdime/tests/test_server_extension.py::test_diff_api_checkpoint
- nbdime/tests/test_web.py::test_api_diff
- nbdime/tests/test_web.py::test_api_merge
- nbdime/tests/test_web.py::test_fetch_diff
- nbdime/tests/test_web.py::test_fetch_merge
- nbdime/tests/test_web.py::test_offline_mathjax
-)
-
-python_configure_all() {
- DISTUTILS_ARGS=( --skip-npm )
-}
-
-src_test() {
- # user.email and user.name are not configured in the sandbox
- git config --global user.email "larry@gentoo.org" || die
- git config --global user.name "Larry the Cow" || die
-
- distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- mv "${ED}"{/usr,}/etc || die
-}