summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/miller/Manifest1
-rw-r--r--sys-apps/miller/miller-5.10.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/miller/Manifest b/sys-apps/miller/Manifest
index a91a7d449c55..59a024e51dca 100644
--- a/sys-apps/miller/Manifest
+++ b/sys-apps/miller/Manifest
@@ -1 +1,2 @@
DIST miller-5.10.0.tar.gz 6793426 BLAKE2B 25ec96e29ee8d913feffd6e9a54cd2d494c9050e180556ed462a6d94a6adaaea88dbdbc09b4753f8888673bdc33a1f0aa43f9dac37bdc3c25191b2a565fe8847 SHA512 a7cbaee9ad4075d27e74ab3a60297164c535ea2bc1e38128174f4f226ad061850d37108e7d7547821b7e6667cb9a024639795d7678b1897fedf6ee15d6064538
+DIST miller-5.10.1.tar.gz 6158587 BLAKE2B f22db3ccd29e0ff99e3f287e7e4382d679bba2c4d8e0fef3f3c086fa11ffbb287c22fc69c23f3baf647c2e5ac020d73f55ee613b0bb71273d7f94a5fe9561ea5 SHA512 32ec8216ea9c73c20b5c22fa047535c37f52a0d3c3c1100b090c57011cd555cae57a56425dfb0eaf0d09d41d82dbea3ad78a182ec8b538e194599b754f562961
diff --git a/sys-apps/miller/miller-5.10.1.ebuild b/sys-apps/miller/miller-5.10.1.ebuild
new file mode 100644
index 000000000000..4f24e895c456
--- /dev/null
+++ b/sys-apps/miller/miller-5.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A tool like sed, awk, cut, join, and sort for name-indexed data (CSV, JSON, ..)"
+HOMEPAGE="https://johnkerl.org/miller/doc/index.html"
+SRC_URI="https://github.com/johnkerl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+
+ # Respect flags
+ find -type f -name "Makefile.am" -exec sed -i -r -e '/.*FLAGS[^=]*=/ s:(-g|-pg|-O[0-9]) ::g' -- {} \; || die
+
+ # Disable docs rebuilding as they're shipped prebuilt
+ sed -e '/SUBDIRS[^=]*=/ s:doc::g' -i -- Makefile.am || die
+
+ # Disable building tests automagically
+ if ! use test; then
+ sed -e '/SUBDIRS[^=]*=/ s:[^ ]*_test::g' -i -- c/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_test() {
+ emake -C c/reg_test
+ emake -C c/unit_test
+}
+
+src_install() {
+ local HTML_DOCS=( $(usev doc) )
+
+ default
+
+ doman docs/mlr.1
+}