summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-32.0.0.142.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index ed780f80f807..7e2647d30eb6 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-32.0.0.114-npapi.i386.tar.gz 8530200 BLAKE2B b069569484424ec5b9
DIST adobe-flash-32.0.0.114-npapi.x86_64.tar.gz 9045986 BLAKE2B b496311016dc6b0f4912a8c5c8cd929a1b32d87300a13a90675bb9626689baccf98f56d2ce5619eda50c278b6e52c29a2ce9a08166cd48330d56034e09b65673 SHA512 41b20377570fe0ec0609b0f39432dc06114e40d97ecb791ad97928028984c4bc5a6b7b68fd14bc754f5c316842661056f716ff1c224029e8b46e4bd2a00744e5
DIST adobe-flash-32.0.0.114-ppapi.i386.tar.gz 8564095 BLAKE2B e4b9f531b199d932a8041812eb7d7409efe3db39e74f8feb928e25006a4b62bde8690faef137c729a1972ed50e8182440a1e6638b3f00856cbcb502c8d337254 SHA512 7b18dff8adc2ca16ef46ac9281df840a76aaa36daa353b7233c2a2df756c603c78cbc4bb03a7abec48f4235cee8a630ae3435443dc82940c8696bb7a4fa1b787
DIST adobe-flash-32.0.0.114-ppapi.x86_64.tar.gz 9482535 BLAKE2B 8f3c6cfd3ddcd1d099d7893e45c432229516bb6853abdd0774e9a29bc567e635f431a5635e6c8090d2a794d8541a2ca6382af2f8fe555331cd19d30abbc2fe2a SHA512 4d6d8dc9430e6008a945bcafcd3c4c796f5b7620d1f3bbf0c14ad4c7f151b6cf2a434184b14d061eb53c7f0cfbe10121a747624a8f6ffbec2e7b58a23e097a8a
+DIST adobe-flash-32.0.0.142-npapi.i386.tar.gz 8530350 BLAKE2B 78faf86c16bb5e6eda333e4731f62a7388e69921c6d951f437ac6e82920f90855638851c5186e43b16fa492e2d83482ab0de6ca7c374a0288d82096e24c6de01 SHA512 9f12147d89e83c954c49c949aa29d987f54d1be47fbac281a9d9dcca38d04fc23f8c7860b46886d235bde7a806f89eaf5483bc9307419313ef3d779c5c30a188
+DIST adobe-flash-32.0.0.142-npapi.x86_64.tar.gz 9047544 BLAKE2B e14cca8120405ec265168b3dfd43ce81c180f68f38dcb59a560115395e169550b2738cbf8821cadf12e1e8b868e6c588295e8926f55747e2c8bddfaa9e1d329d SHA512 047086d43902b3132358ed0c53dde26108bc4e69067945e6194cf5aaaf96f1f01921a8a0a08cd7ac6006bcaee08880a59e46a5c621c6dd6e306af419d65e03e1
+DIST adobe-flash-32.0.0.142-ppapi.i386.tar.gz 8565686 BLAKE2B 8241352527e58057635581aa1f12c412c690ca5c119c70ff81f5178c0e6f0c3e0c5f5a4ab53a5d5729807d7f9a2c9e2ab4fcd8896cb9399f44996a9d11056c55 SHA512 942e8efc3eaa2674d4b0fbcfe46f50a0ce1a5a5ae87055419d4cea7b710083779b6803271042b4c3ca457a925ede13cc532ac7b8e5f4adfaa9ce932fa9e61417
+DIST adobe-flash-32.0.0.142-ppapi.x86_64.tar.gz 9482227 BLAKE2B 6b91b802541058e7bc20a120c58d731684c98ce5719c24d48cd2a68307af15dfb399265af49c1f5e559391835a23fc8b1509b4a0c2b228efbc789d9a4f07fb20 SHA512 1ee8994ce485b72fc97967f8c4229a7c688518f3c05238063c493e320927164a3bf225fbdcb064d6502fb9ec2bddfd30857400daf39520d41153e95ae9cb3ef9
diff --git a/www-plugins/adobe-flash/adobe-flash-32.0.0.142.ebuild b/www-plugins/adobe-flash/adobe-flash-32.0.0.142.ebuild
new file mode 100644
index 000000000000..2cc1c70b340d
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-32.0.0.142.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}