summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 5 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 9808186cdc9a..ebc82a42d665 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -90,9 +90,9 @@ FFMPEG_FLAG_MAP=(
# Same as above but for encoders, i.e. they do something only with USE=encode.
FFMPEG_ENCODER_FLAG_MAP=(
aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame
- aacplus:libaacplus faac:libfaac snappy:libsnappy theora:libtheora
- twolame:libtwolame wavpack:libwavpack webp:libwebp x264:libx264 x265:libx265
- xvid:libxvid
+ aacplus:libaacplus faac:libfaac openh264:libopenh264 snappy:libsnappy
+ theora:libtheora twolame:libtwolame wavpack:libwavpack webp:libwebp
+ x264:libx264 x265:libx265 xvid:libxvid
)
IUSE="
@@ -165,6 +165,7 @@ RDEPEND="
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
faac? ( >=media-libs/faac-1.28-r3[${MULTILIB_USEDEP}] )
mp3? ( >=media-sound/lame-3.99.5-r1[${MULTILIB_USEDEP}] )
+ openh264? ( >=media-libs/openh264-1.4.0-r1[${MULTILIB_USEDEP}] )
snappy? ( >=app-arch/snappy-1.1.2-r1[${MULTILIB_USEDEP}] )
theora? (
>=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}]
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index ab2aef51409c..a987be4387e6 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -34,6 +34,7 @@
<flag name="mipsdspr2">Enables MIPS DSP ASE R2 optimizations.</flag>
<flag name="mipsfpu">Enables floating point MIPS optimizations.</flag>
<flag name="network">Enables network streaming support</flag>
+ <flag name="openh264">Enables H.264 encoding suppoprt via <pkg>media-libs/openh264</pkg>.</flag>
<flag name="openssl">Enables <pkg>dev-libs/openssl</pkg> support. Adds support for encrypted network protocols (TLS/HTTPS).</flag>
<flag name="opus">Adds (decoding) support for the Opus codec via <pkg>media-libs/opus</pkg>.</flag>
<flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>