summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/opendylan/Manifest3
-rw-r--r--dev-lang/opendylan/metadata.xml8
-rw-r--r--dev-lang/opendylan/opendylan-2013.1-r1.ebuild100
-rw-r--r--dev-lang/opendylan/opendylan-2013.2.ebuild105
-rw-r--r--dev-lang/opendylan/opendylan-2014.1.ebuild101
-rw-r--r--dev-lang/opendylan/opendylan-9999.ebuild64
-rw-r--r--profiles/package.mask1
7 files changed, 0 insertions, 382 deletions
diff --git a/dev-lang/opendylan/Manifest b/dev-lang/opendylan/Manifest
deleted file mode 100644
index ad68d4e2d033..000000000000
--- a/dev-lang/opendylan/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST opendylan-2013.1-sources.tar.bz2 8441356 BLAKE2B 5dad47af5ccd5bb760c8fd0e83faf6442f43b47c985731cd3b2fae5644f5dbc96150050f3fa19110391ae36bbd1a68d0e51ae6d5ac95407c38a3fcfebf8425cf SHA512 f5168bb9a4d2bcd372667406f2f07ed5972f3e773a5766c5f74421d6ffd10901a43cf9d6604ad2ae14d80f1b84e856f4fdca3e1546a87053939f470005a87a2f
-DIST opendylan-2013.2-sources.tar.bz2 9174284 BLAKE2B 124af65a76c3f795a90f8220ca499fa822e329e33be2b322d63b77a82880e18b3b665968a726ecbfa1888c29b62b9a11f3a568b222ef18dfab38c3ae05bfdf23 SHA512 f846a1d80f78b887815d2f2983314dbf6b5f424164dba9bc6ac456b40f31ab02aeb073a447df8f02b3fad6bcf6401a889abaac400d58db8e0adebcdd4e177a4d
-DIST opendylan-2014.1-sources.tar.bz2 8232321 BLAKE2B 45535287a2d85617e0461da4dfcd93f1f95249a7c191732624129174c6696411b3cf2a3cd85bb9eaa26c3723689d1ebfbb812fabb3a8d3e2ac5cfd7f4ee284f9 SHA512 576616cad0eb6ff8606a394834ad325858a5f45a8427adb0eefc9ebf883ab1522ec66dff6e591a367390d49f53acd160becad62679edc610ccfe63c9a3795cfc
diff --git a/dev-lang/opendylan/metadata.xml b/dev-lang/opendylan/metadata.xml
deleted file mode 100644
index 40aa45df2b01..000000000000
--- a/dev-lang/opendylan/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild b/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
deleted file mode 100644
index 78ee3789828b..000000000000
--- a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools
-
-DESCRIPTION="OpenDylan language runtime environment"
-HOMEPAGE="http://opendylan.org"
-SRC_URI="http://opendylan.org/downloads/${PN}/${PV}/${P}-sources.tar.bz2"
-
-LICENSE="Opendylan"
-SLOT="0"
-# not tested on x86
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-# the boehm-gc check is "wrong" and reported upstream
-# but for now static-libs useflag is needed
-DEPEND="app-arch/unzip
- dev-libs/boehm-gc
- dev-lang/perl
- dev-perl/XML-Parser
- || ( dev-lang/opendylan-bin dev-lang/opendylan )
- x86? ( <dev-libs/mps-1.108 )"
-RDEPEND="${DEPEND}"
-
-# on x86 there's a dependency on mps, but the build system is a bit ... hmm ...
-# let's give it more of a chance to survive then
-NAUGHTY_FILES=(
- sources/lib/run-time/collector.c.malloc
- sources/lib/run-time/collector.c
- sources/lib/run-time/pentium-win32/buffalo-collector.c
- sources/lib/run-time/pentium-win32/heap-stats.c
- sources/lib/run-time/heap-utils.h
- )
-
-NAUGHTY_HEADERS=(
- mps.h
- mpscmv.h
- mpscamc.h
- mpsavm.h
- )
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- mkdir -p build-aux
- elibtoolize && eaclocal || die "Fail"
- automake --foreign --add-missing # this one dies wrongfully
- eautoconf || die "Fail"
- # mps headers, included wrong
- if use x86; then
- for i in ${NAUGHTY_FILES[@]}; do
- for header in ${NAUGHTY_HEADERS[@]}; do
- sed -i -e "s:\"${header}\":<${header}>:" $i
- done
- done
- fi
-}
-
-src_configure() {
- if has_version =dev-lang/opendylan-bin-2013.1; then
- PATH=/opt/opendylan-2013.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2012.1; then
- PATH=/opt/opendylan-2012.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2011.1; then
- PATH=/opt/opendylan-2011.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin:$PATH
- fi
- if use amd64; then
- econf --prefix=/opt/opendylan
- else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
- fi
- if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- sed -i -e 's~$(MPS_LIB)/mmdw.a~/usr/lib/mmdw.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- fi
-}
-
-src_compile() {
- ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap
-}
-
-src_install() {
- ulimit -s 32000 # this is naughty build system
- # because of Makefile weirdness it rebuilds quite a bit here
- # upstream has been notified
- emake -j1 DESTDIR="${D}" install
- mkdir -p "${D}/etc/env.d/opendylan/"
- echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
-}
diff --git a/dev-lang/opendylan/opendylan-2013.2.ebuild b/dev-lang/opendylan/opendylan-2013.2.ebuild
deleted file mode 100644
index 60566f683474..000000000000
--- a/dev-lang/opendylan/opendylan-2013.2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="OpenDylan language runtime environment"
-HOMEPAGE="http://opendylan.org"
-SRC_URI="http://opendylan.org/downloads/${PN}/${PV}/${P}-sources.tar.bz2"
-
-LICENSE="Opendylan"
-SLOT="0"
-# not tested on x86
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-# the boehm-gc check is "wrong" and reported upstream
-# but for now static-libs useflag is needed
-DEPEND="app-arch/unzip
- dev-libs/boehm-gc[threads]
- dev-lang/perl
- dev-perl/XML-Parser
- || ( dev-lang/opendylan-bin dev-lang/opendylan )
- x86? ( <dev-libs/mps-1.108 )"
-RDEPEND="${DEPEND}"
-
-# on x86 there's a dependency on mps, but the build system is a bit ... hmm ...
-# let's give it more of a chance to survive then
-NAUGHTY_FILES=(
- sources/lib/run-time/collector.c.malloc
- sources/lib/run-time/collector.c
- sources/lib/run-time/pentium-win32/buffalo-collector.c
- sources/lib/run-time/pentium-win32/heap-stats.c
- sources/lib/run-time/heap-utils.h
- )
-
-NAUGHTY_HEADERS=(
- mps.h
- mpscmv.h
- mpscamc.h
- mpsavm.h
- )
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- # configure autodetects clang and prefers it, #527108
- sed -i -e 's/clang//' configure.ac || die
- mkdir -p build-aux
- elibtoolize && eaclocal || die "Fail"
- automake --foreign --add-missing # this one dies wrongfully
- eautoconf || die "Fail"
- # mps headers, included wrong
- if use x86; then
- for i in ${NAUGHTY_FILES[@]}; do
- for header in ${NAUGHTY_HEADERS[@]}; do
- sed -i -e "s:\"${header}\":<${header}>:" $i
- done
- done
- fi
-}
-
-src_configure() {
- if has_version =dev-lang/opendylan-bin-2013.2; then
- PATH=/opt/opendylan-2013.2/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2013.1; then
- PATH=/opt/opendylan-2013.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2012.1; then
- PATH=/opt/opendylan-2012.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2011.1; then
- PATH=/opt/opendylan-2011.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin:$PATH
- fi
-
- if use amd64; then
- econf --prefix=/opt/opendylan
- else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
- fi
- if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- sed -i -e 's~$(MPS_LIB)/mmdw.a~/usr/lib/mmdw.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- fi
-}
-
-src_compile() {
- ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap
-}
-
-src_install() {
- ulimit -s 32000 # this is naughty build system
- # because of Makefile weirdness it rebuilds quite a bit here
- # upstream has been notified
- emake -j1 DESTDIR="${D}" install
- mkdir -p "${D}/etc/env.d/opendylan/"
- echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
-}
diff --git a/dev-lang/opendylan/opendylan-2014.1.ebuild b/dev-lang/opendylan/opendylan-2014.1.ebuild
deleted file mode 100644
index 9bf1ebb1bece..000000000000
--- a/dev-lang/opendylan/opendylan-2014.1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="OpenDylan language runtime environment"
-HOMEPAGE="http://opendylan.org"
-SRC_URI="http://opendylan.org/downloads/${PN}/${PV}/${P}-sources.tar.bz2"
-
-LICENSE="Opendylan"
-SLOT="0"
-# not tested on x86
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-# the boehm-gc check is "wrong" and reported upstream
-# but for now static-libs useflag is needed
-DEPEND="app-arch/unzip
- dev-libs/boehm-gc[threads]
- dev-lang/perl
- dev-perl/XML-Parser
- || ( dev-lang/opendylan-bin dev-lang/opendylan )
- x86? ( <dev-libs/mps-1.108 )"
-RDEPEND="${DEPEND}"
-
-# on x86 there's a dependency on mps, but the build system is a bit ... hmm ...
-# let's give it more of a chance to survive then
-NAUGHTY_FILES=(
- sources/lib/run-time/collector.c.malloc
- sources/lib/run-time/collector.c
- sources/lib/run-time/pentium-win32/buffalo-collector.c
- sources/lib/run-time/pentium-win32/heap-stats.c
- sources/lib/run-time/heap-utils.h
- )
-
-NAUGHTY_HEADERS=(
- mps.h
- mpscmv.h
- mpscamc.h
- mpsavm.h
- )
-
-src_prepare() {
- # configure autodetects clang and prefers it, #527108
- sed -i -e 's/clang//' configure.ac || die
- mkdir -p build-aux
- elibtoolize && eaclocal || die "Fail"
- automake --foreign --add-missing # this one dies wrongfully
- eautoconf || die "Fail"
- # mps headers, included wrong
- if use x86; then
- for i in ${NAUGHTY_FILES[@]}; do
- for header in ${NAUGHTY_HEADERS[@]}; do
- sed -i -e "s:\"${header}\":<${header}>:" $i
- done
- done
- fi
-}
-
-src_configure() {
- if has_version =dev-lang/opendylan-bin-2014.1; then
- PATH=/opt/opendylan-2014.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2013.2; then
- PATH=/opt/opendylan-2013.2/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2013.1; then
- PATH=/opt/opendylan-2013.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin:$PATH
- fi
-
- if use amd64; then
- econf --prefix=/opt/opendylan
- else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
- fi
- if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- sed -i -e 's~$(MPS_LIB)/mmdw.a~/usr/lib/mmdw.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- fi
-}
-
-src_compile() {
- ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap
-}
-
-src_install() {
- ulimit -s 32000 # this is naughty build system
- # because of Makefile weirdness it rebuilds quite a bit here
- # upstream has been notified
- emake -j1 DESTDIR="${D}" install
- mkdir -p "${D}/etc/env.d/opendylan/"
- echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
-}
diff --git a/dev-lang/opendylan/opendylan-9999.ebuild b/dev-lang/opendylan/opendylan-9999.ebuild
deleted file mode 100644
index adf7e63d28bd..000000000000
--- a/dev-lang/opendylan/opendylan-9999.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-EGIT_SUBMODULES=( '*' )
-EGIT_REPO_URI="https://github.com/dylan-lang/opendylan.git"
-
-inherit autotools git-r3
-
-DESCRIPTION="OpenDylan language runtime environment"
-HOMEPAGE="http://opendylan.org"
-
-LICENSE="Opendylan"
-SLOT="0"
-IUSE=""
-RESTRICT="test"
-
-DEPEND="dev-libs/boehm-gc[threads]
- dev-lang/perl
- dev-perl/XML-Parser
- || ( dev-lang/opendylan-bin dev-lang/opendylan )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- mkdir -p build-aux
- elibtoolize && eaclocal || die "Fail"
- automake --foreign --add-missing # this one dies wrongfully
- eautoconf || die "Fail"
-
- # quick hack
- sed -i -e 's:/usr/local:/usr:' admin/builds/fdmake.pl || die
-}
-
-src_configure() {
- if has_version =dev-lang/opendylan-bin-2014.1; then
- PATH=/opt/opendylan-2014.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2013.2; then
- PATH=/opt/opendylan-2013.2/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2013.1; then
- PATH=/opt/opendylan-2013.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2012.1; then
- PATH=/opt/opendylan-2012.1/bin/:$PATH
- elif has_version =dev-lang/opendylan-bin-2011.1; then
- PATH=/opt/opendylan-2011.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin/:$PATH
- fi
- econf --prefix=/opt/opendylan
-}
-
-src_compile() {
- ulimit -s 32000 # this is naughty build system
- emake -j1
-}
-
-src_install() {
- ulimit -s 32000 # this is naughty build system
- # because of Makefile weirdness it rebuilds quite a bit here
- # upstream has been notified
- emake -j1 DESTDIR="${D}" install
- mkdir -p "${D}/etc/env.d/opendylan/"
- echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/opendylan" || die "Failed to add env settings"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 6a110f4c62f1..fb1b3f7834a5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -677,7 +677,6 @@ dev-ml/xstr
# Aaron Bauman <bman@gentoo.org> (2019-12-12)
# EAPI 4, new versions upstream, not bumped
# Removal in 30 days
-dev-lang/opendylan
dev-libs/mps
# David Seifert <soap@gentoo.org> (2019-12-08)