summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index ba2bcfca0c12..53b2aa628bd3 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.3.0.tar.gz 880508 BLAKE2B 426c0582ffad734cae2f66826aa04b2db791a110abc79629f4e3b71a69db354b56d213feae6d807f3b7a3f2906aac00fc50c49eaf3dc7d8e09783f59c99ef4e5 SHA512 b1f47c8f500aa684a8cabcff916b6a1e41230d949a35d57c80f13734f6f88f8c3a31d99f64cc1f6e316d26710da894670f130baf78fec5ecf3a70a70f0d7417a
DIST airdcpp-webclient-2.4.0.tar.gz 899040 BLAKE2B a498624fb273ecc756c6d1ce9fc6ebc4b44e0e6788ae41208a308d9e204a4657503e9123c7ed41c9a5d1ffca6a1eda54a3fdddb609244cea54b41605927281d9 SHA512 6598fd6bebae65381dd97763da4a69ce32e4d3f5cb16e5cbd66bd29d973e36c3a616138c84426c462cfd275b39b8d4bd4c0162de9dba3c02b603735ad842a3a7
+DIST airdcpp-webclient-2.5.0.tar.gz 900078 BLAKE2B 53f5e096a3a6cc7c77c92bef32a7aaf0fb7b5e49740718252c7b4e233b80c52ca27029ba24fef4f1ab9c4c360da182accffb8ba7de27ef9b0b4aaa011005b689 SHA512 cf0220e3f2096304e393a4bd833e81c1427dbd144a56498712c9e18f2ec14f35d9112ad0ff05f54aad5a57126d68fc46c2bf20806dd7464a5bdb301543b08809
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.0.ebuild
new file mode 100644
index 000000000000..0a48a02f89a5
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.5.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}