summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.24.4-r1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 9c408f778335..bb4c9d3b1e8c 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,2 +1 @@
-DIST tox-3.24.4.tar.gz 306760 BLAKE2B 332c99d021bc3c25549fd95d051baaa1f0dc3aaf776928320826bb7e6bce6444fd5a993e1dbff3a4ebbde9dbb59e30d07eae4b04096294b3a186b130b8312587 SHA512 49e2cb74f119b5cc049d2a64479e56307cea1f36a5586840cca12cb8f4ce8a2ba991cc6142bef7f095a7d32b44f7513f89cce56d89deaff0e12194ceb3da6249
DIST tox-3.24.5.tar.gz 306305 BLAKE2B a6d3338d21068d9123505a29da3beec4fd5a15c263bcaf5ba62f65a253d04e11d453bef159d06e88b2cbac9a895d786d0d9444cc16cd3de7a868eac6919b82ea SHA512 4e1ef81c978977e905edbdc00ff971eb4132b9009ce21456fcebf95d8ee2c583e04e464f1db5ca6e5454f4f1ad0353ffc9df7898f6389fe8084dc5b9726ca59b
diff --git a/dev-python/tox/tox-3.24.4-r1.ebuild b/dev-python/tox/tox-3.24.4-r1.ebuild
deleted file mode 100644
index e23a2e4b7f90..000000000000
--- a/dev-python/tox/tox-3.24.4-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
-SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-# doc disabled because of missing deps in tree
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- >=dev-python/six-1.14[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
-# TODO: figure out how to make tests work without the package being
-# installed first.
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken without Internet
- tests/unit/session/test_provision.py::test_provision_non_canonical_dep
- tests/integration/test_provision_int.py::test_provision_interrupt_child
-
- # expects python2 to exist
- tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
-
- # fragile and relies on checking stdout
- tests/unit/util/test_spinner.py::test_spinner_progress
- )
-
- [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
- # TODO?
- tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
-
- # broken without tox installed first
- # TODO: why it can't import itself?
- tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
- )
-
- distutils_install_for_testing --via-venv
- epytest --no-network
-}