summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/most/Manifest1
-rw-r--r--sys-apps/most/most-5.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/most/Manifest b/sys-apps/most/Manifest
index d1ffb632d48d..3ac82c0380ba 100644
--- a/sys-apps/most/Manifest
+++ b/sys-apps/most/Manifest
@@ -1 +1,2 @@
DIST most-5.1.0.tar.gz 162172 BLAKE2B a3c0f3d85e7c4f4a014c174efb0d3d22b0fc2758e403ddccc74308399eeec616800e16db33554f0ca53fba674efba9dd93d51ed0c3f887b2c24fd3dd2335387c SHA512 cbc090283bbaafb8ffee9d6d1abc7b49cd58d54b742cf8dc86274351dee6398d1f24841bd1631ac40f861ad9e23569646133d3297317d9d514a7a38dd74533d2
+DIST most-5.2.0.tar.gz 256075 BLAKE2B ae73680cedb0306dd6980c637fd8c0d016537663ab707e925931972822f718dd31fc80d83598af9832c7869b5abf4ec3333bc076ce56c4a6d42f71d30be1a50d SHA512 3aa3cb46ddd456532a009fb9cfcd746971396be33e03e52a15b754a6d7683f4efd020edb0ec4eb36d22ba20f050aaac4ba6cdd3b69bb5701ea58ddb9a903c59d
diff --git a/sys-apps/most/most-5.2.0.ebuild b/sys-apps/most/most-5.2.0.ebuild
new file mode 100644
index 000000000000..20f8f9098a74
--- /dev/null
+++ b/sys-apps/most/most-5.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Paging program that displays, one windowful at a time, the contents of a file"
+HOMEPAGE="https://www.jedsoft.org/most/"
+SRC_URI="https://www.jedsoft.org/releases/${PN}/${P}.tar.gz
+ https://www.jedsoft.org/releases/${PN}/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND=">=sys-libs/slang-2.1.3"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.0a-donot-hardcode-path.patch
+)
+
+src_prepare() {
+ default
+ # Do not strip by default
+ sed -e '/\$(INSTALL)/s@ -s@@' -i src/Makefile.in || die
+}
+
+src_configure() {
+ unset ARCH
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+}